Skip to Content

GLPCA-MSL issue : need to display 54 instead of 54.000,000

Hello All,

I need to display the GLPCA-MSL in this format NN not NN.NNN,NNN as it is now

In debug i have in my internal table (GT_TAB) :MSL = 54000.000

and when i display ALV ( 54.000,000)

You see that it is converted from 54000.000 to 54.000,000

I need to display just 54 instead of 54.000,000

I use the REUSE_ALV_GRID_DISPLAY

and the field catalog is filled like this

********************************************************

Build fieldcatalog

*********************************************************

clear ls_fieldcat.
ls_fieldcat-col_pos = '4' .
ls_fieldcat-fieldname = 'MSL'.
ls_fieldcat-tabname = 'GT_TAB'.
ls_fieldcat-outputlen = 19.
ls_fieldcat-seltext_l = text-007.
ls_fieldcat-emphasize = ' '.
ls_fieldcat-do_sum = 'X'.
append ls_fieldcat to gt_fcat.

***********************************************************

i don't think the solution is to change the user parameters

Thanks for your response in advance,

Regards

Rachid

tab1.png (9.4 kB)
tab2.png (3.2 kB)
usr01.png (4.3 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Jul 04, 2019 at 09:03 AM

    Add another column to your report data. Fill that with your values divided by 1000. You could make it an integer or type P with zero decimals or whatever. In the field catalog set the original value field to technical (so won't and can't be displayed), and use your new field as the display value field.
    Furthermore - ditch the use of REUSE_ALV_GRID_DISPLAY. Learn to use CL_SALV_TABLE instead - it's far more flexible and much easier to use.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 04, 2019 at 08:36 AM
    -1

    I add in my fieldcatalog the parameter decimals_out = '0' and i devide the field by 1000 in the result i have now 54 instead of 54.000,000

    what do you think ?

    Add a comment
    10|10000 characters needed characters exceeded

    • I think you should post comments as comments, not answers. From the text next to the Your Answer field:

      You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.