Skip to Content

Time Evaluation form for previous dates is generated

Hi HCM,

I am facing a strange problem regarding Time Management. When I execute the Time Evaluation PT60, the form is generated from previous dates that is 28.09.2018. When I check the cluster table B1 (PT_CLSTB1) and enter the employee number to view the details, it shows me 2 entries for the date 28.09.2018 in NT2 table (Screenshot attached). I have executed the time evaluation live from previous dates evens and checked the TEVEN table as well. I could not diagnose what is the actual issue. The PDC recalcuation date in IT0003 is absolutly fine

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Posted on Jun 27, 2019 at 09:04 AM

    Hi Sam,

    Screenshot is missing; however, generally NT2 table shows IT2011 entries which are open or missing entries or not is pairs not processed.

    Providing correct clock data and correcting missing/incorrect clock data is client's responsibility.

    You/client need/s to correct those clock entries. Once you correct those entries it may / may not impact time data depending on errors you have in NT2 table. If you don't want to or can not correct clock data then please update earl. retro date for time eval from your expected date. It will not affect any time eval result.

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi thank you for the prompt response. The entries in IT2011 are perfectly fine and evaluated with assignment sign '=' successfully. Also I check the error report and there is no error for the employee number for the given dates. However, still the form is generated from previous dates. s1.png The dates in table NT2 do not clear even the time evaluation is executed forcefully from the previous dates.

      s1.png (44.0 kB)
  • Posted on Jun 27, 2019 at 10:28 AM

    Hi,

    Can you screenshoot your NT1 and NT2 tables?

    bg

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi,

      Are there are no clues among the 35 messages on the 'ERT' table?.

      On the face of it there is nothing amis with NT2!

      It may not be relevant but I see those clock entries were entered manually. What I would do is check the following.

      Examine the full record on TEVEN (IT2011) thru SE16N for the 28.09.2018 and compare to subsequent and if exists previous entries for this employee and see if there is any discrepency with the field contents, does anything look a little different or odd.

      I would simulate time for that day and confirm that the those swipes get evaluated as expected and the appropriate time types, wage types etc etc get generated.

      If the the day is being processed correctly it makes no sence to have those entries left on the 'NT2'

      Also step thru the log specifically where it pulls in the time events and updates the 'TIP' table.

      Take a look at the 'B1' cluster results - 'FEHLER' and 'BEZUG' anything there

      If at the end of the day you are happy there are no issues and that the employees time results are correct you can just delete the 'B1' cluster entry for that employee.

      bg

  • Posted on Jul 01, 2019 at 04:16 AM

    I deleted the B1 cluster and the issue is resolved. Now I am opening a new thread to confirm if it is recommended to delete B1 cluster in Production Server.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.