Skip to Content
0
Jun 26, 2019 at 03:26 PM

Unable to connect inbound calls

332 Views Last edit Jul 02, 2019 at 03:01 PM 2 rev

Hi everyone,

We are having an issue with inbound calls even when outbound are properly working. The SIP Gateway we have is:

HUAWEI-EchoLife HG8245Q2/V3R018C10S115

The logs that gateway is providing show the following information:

Sip gateway component within PSTN VU shows the following information in logs:

------------------------------------------------------------------------------------------------

10:32:03.298 (07740 ) ERR> Sip request message (size: 1461, message_size: 1461) decoding - Parser error: expected that line ends with newline at pos 891

10:32:03.298 (07740 ) ERR> message dump:

INVITE tel:+96822400501 SIP/2.0

Via: SIP/2.0/ UDP10.225.78.153:5060;branch=z9hG4bK4nd35cycg5og3jy3ncmggnd4r;Role=3;Hpt=8e68_16;TRC=386-ffffffff

Record-Route: <sip:10.225.78.153:5060;transport=udp;lr;Hpt=8e68_16;CxtId=4;TRC=386-ffffffff;X-HwB2bUaCookie=546>

Call-ID: isbct57b429462599y8fa374tu97y2faua8u@B.5.103.ims.awasr.om

From: <tel:22400020;noa=subscriber;srvattri=national;phone-context=+968>;tag=2isshfac

To: <tel:22400501>

CSeq: 1 INVITE

Accept: application/sdp,application/simservs+xml

Allow: INVITE,ACK,OPTIONS,BYE,CANCEL,REGISTER,INFO,PRACK,SUBSCRIBE,NOTIFY,UPDATE,MESSAGE,REFER Contact: <sip:10.225.78.153;transport=udp;Dpt=f2aa-200;Hpt=8e68_16;CxtId=4;TRC=386-ffffffff>

Max-Forwards: 61

Supported: timer,100rel,replaces,privacy

User-Agent: HUAWEI-EchoLife HG8245Q2/V3R018C10S115

Session-Expires: 1800

Min-SE: 600

P-Asserted-Identity: +96822400020@ims.awasr.om>,

P-Access-Network-Info: IEEE-802.11;"sbc-domain=msq-abcf-1.ims.awasr.om";"ue-ip=161.123.101.159";"ue-port=5060"

P-Charging-Vector: icid-value="msq-pcscf-VOBB.191.176d.20190625103201";orig-ioi=AWASR;term-ioi=1 P-Early-Media: gated

Content-Length: 263

Content-Type: application/sdp

------------------------------------------------------------------------------------------------

The only difference I see if I compare this logs with one in a working system, is before every phone number appears a "tel:" instead of "sip:". Searching about those are protocols so we hope there is no problem with device compatibility:

logs for failing environment:

INVITE tel:+96822400501 SIP/2.0

Via: SIP/2.0/UDP 10.225.78.153:5060;branch=z9hG4bK4nd35cycg5og3jy3ncmggnd4r;Role=3;Hpt=8e68_16;TRC=386-ffffffff

Record-Route: <sip:10.225.78.153:5060;transport=udp;lr;Hpt=8e68_16;CxtId=4;TRC=386-ffffffff;X-HwB2bUaCookie=546>

Call-ID: isbct57b429462599y8fa374tu97y2faua8u@B.5.103.ims.awasr.om

From: <tel:22400020;noa=subscriber;srvattri=national;phone-context=+968>;tag=2isshfac

To: <tel:22400501>

logs in working fine environment:

INVITE sip:5640;phone-context=cdp.udp@ferreyros.com.pe:5060;maddr=172.16.16.237;transport=tcp;user=phone;x-nt-redirect=redirect-server SIP/2.0

From: <sip:955003395@ferreyros.com.pe;user=phone>;tag=88a38b8-a01640a-13c4-55013-5317a0-45eb6585-5317a0

To: <sip:5640@ferreyros.com.pe;user=phone>

Any hint or idea will be very appreciated. Thanks in advance.

Shankar Vangari

Attachments

huawei-gw-logs.png (372.2 kB)