Skip to Content

Accepting Free text as in entity

Hi folks,

is there any way to accept plain text/line in the entity not in Intents of SAP Conversational AI. For example: if user says: "We had issue regarding hotel". I wants to identify this sentence as in entity.

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Jun 14, 2019 at 08:08 AM

    Hi Amol Saudatr

    To understand how to save a entry free text, you can have a look on the following tutorial: https://cai.tools.sap/blog/mastering-memory-management-bot-builder where we explain it :)

    Best regards,

    Aurélie

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 19, 2019 at 06:13 PM

    Hi Amol Saudatr, in the link that Aurelie give you. you have the answer, but is somehow hidden.

    To be able to put a free entry you actually use a workaround or a little trick.

    When you type something to the chat it will evaluate with skill to trigger if nothing is found you get the "fallback", so to avoid this. You have to apriori call a skill in wich you will save the user entry.

    How ? What you do is set a memory "flag" let´s say wait_feedback = true and redirect to a skill "save_feedback" and WAIT FOR USER INPUT, in that skill the trigger should be that the wait_feedback flag is present so the skill will be trigger, with no requirement and in the action part you set a memory field "feedback" = {{nlp.source}}

    {{nlp.source}} -> Has the message that the user input. So then you could pass that value to a webhook or using wharever you like.

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Rodrigo Ariel Giner de la Vega, I used this method and it worked fine until I tried to save a second input. Do you have any suggestions or tips how to solve that?
      I have 2 fields connected with an AND in the requirements and they redirect to the save input skill with wait for user input.

      The skill waits for the first input and then runs through both actions without waiting for an input, even though the second action has another requirement in the if check. seems like he runs through the first one, goes back to the first skill and then redirects to the save skill and just runs through the action without waiting for input.

      I hope you can help me, I'm loosing my mind with this problem.

      Best regards

      Jannik

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.