Skip to Content
0
Jun 06, 2019 at 02:23 PM

SAP IdM SetPassword in eDirectory Novell

323 Views Last edit Jun 06, 2019 at 02:25 PM 2 rev

Hello, IdM Experts.

We are facing a problem in our development IdM system. We have a business requirement to set initial password into eDirectory Novell system so we created a Sun repository system to do that.

The connection to backend system (eDirectory Novell) is working fine, the initial load and tasks AssignMembership and RevokeMembership are working OK. but when I ran the task CreateSunOne to create the identity in backend system, the password is set in clean text into the attribute userPassword in the eDirectory Novell, and the user is not able to log-in in the backend system, see picture attachment01.png.

To verify what is happening to iManager (Novell Tool), we tried through iManager and we realized that the userPassword was not full filled, and the attributes sasLoginConfiguration and sasLoginConfigurationKey were generated in this process (see picture attachment02.png), after doing that, the user was able log-in in the backend system.

Has anyone seen this problem before?

Best regards, João Paulo.

Attachments

attachment01.png (52.0 kB)
attachment02.png (59.2 kB)