Skip to Content
-1

HANA Express connected to ABAP stack

I want to connect my HANA express to an On Premise NW ABAP stack to consume an xsodata service there. I can connect to my HANA Express engine via the browser because I've updated my local host file on my machine. Trying to connect to it via SM59 (RFC) fails with an error saying that the host refused the connection.

Any ideas? Full disclosure: I am not a basis admin, I am a developer trying to get this to work.

Another potential issue is that my SAP stack is behind my company firewall and my HANA instance is running in SAP CAL on GCP. I'm assuming there is some configuration that has to be done to allow an external server connection.

Any tips would be greatly appreciated.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • May 21 at 08:34 AM

    "

    Another potential issue is that my SAP stack is behind my company firewall and my HANA instance is running in SAP CAL on GCP. I'm assuming there is some configuration that has to be done to allow an external server connection.

    "

    This's possible. How about login into GCP to view your instance and check security rule about firewall or port number setting, e.g. change to allow all port number open, to see whether it works first.

    Add comment
    10|10000 characters needed characters exceeded

  • May 21 at 11:56 PM

    Hi Sarah,

    Just to verify I'm getting this right: HXE is publishing an OData service in xs classic, your RFC is using a destination configured using the external IP address of your instance and port 8090 and if you ping the IP address of the HXE machine from your netweaver instance you get a response? If you don't update the localhost file in your machine, does it still work?

    Cheers,

    Lucia.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Sarah,

      Thanks for providing the relevant information. In HANA Express, by default, XS Advanced needs the name of the host (hxehost) and the port in the request to route it to the right endpoint (your Node.js module with the OData service in this case). If you try the IP address and the port, your request will not get routed and you get an error message. Your RFC config obviously can't use hxehost because it's only mapped in your local laptop and the IP address will get rejected by XSA.

      I suggest you set the IP address in CAL to static and rename the host of your HXE instance to it, so it can be accessed from outside: https://blogs.sap.com/2018/06/20/hana-express-and-xs-advanced-when-you-cannot-modify-the-hosts-file.../