Skip to Content

Eclipse - Errors while installing new software (Neon/oxygen/2018 12/2018-09)

Hi Team,

I am encountering below errors while installing new software. I tried with Eclipse Neon/oxygen/2018 12/2018-09 but encountering same error.

I followed the step by step instructions mentioned in below blog

https://blogs.sap.com/2018/07/31/a-do-it-yourself-step-by-step-guide-how-to-set-up-your-on-premise-system-of-sap-s4hana-1709-at-home-part-ii.-lets-play-with-development-tools-and-abap-programming-model/

Please let me know if I am missing something here.

Cannot complete the install because one or more required items could not be found.
  Software being installed: ABAP Core Development Tools (Developer Edition) 2.94.7 (com.sap.adt.core.devedition.feature.group 2.94.7)
  Missing requirement: samc Model 1.26.0 (com.sap.adt.conn.amc.ui 1.26.0) requires 'bundle org.eclipse.emf.transaction [1.9.0,2.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: ABAP Connectivity 1.26.0 (com.sap.adt.conn.feature.group 1.26.0)
    To: com.sap.adt.conn.amc.ui [1.26.0]
  Cannot satisfy dependency:
    From: ABAP Core Development Tools (Developer Edition) 2.94.7 (com.sap.adt.core.devedition.feature.group 2.94.7)
    To: com.sap.adt.core.feature.group [2.94.7]
  Cannot satisfy dependency:
    From: ABAP Core Development Tools 2.94.7 (com.sap.adt.core.feature.group 2.94.7)
    To: com.sap.adt.conn.feature.group [1.26.0]

Regards,

Muhammed M

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    Posted on May 10, 2019 at 06:07 AM
    -1

    Hi,

    I encountered the below errors when i was trying to add plug-ins from my office network.

    Cannot complete the install because one or more required items could not be found.
      Software being installed:ABAP Connectivity And Integration Development Tools (Developer Edition)1.103.1(com.sap.adt.pitools.tlf.devedition.feature.group1.103.1)
      Missing requirement:ABAP Connectivity And Integration Development Tools (Developer Edition)1.103.1(com.sap.adt.pitools.tlf.devedition.feature.group1.103.1) requires 'org.eclipse.equinox.p2.iu; org.eclipse.emf.query.feature.group [1.7.0,2.0.0)' but it could not be found

    I tried from my home network,it worked perfectly fine. I was able to install the ADT plug-inns.

    Regards,

    Muhammed M

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 07, 2019 at 07:10 AM
    -1

    Hello,

    try it with a newer version of eclipse. SAP only supports the last two versions of Eclipse. The newest is "Eclipse 2019-06".

    Best regards

    Marco

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 07, 2019 at 08:18 AM
    -1

    Hello,

    did you use this link to get the Plugins?

    https://tools.hana.ondemand.com/2019-03

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.