Skip to Content

SRM: FM - BBP_OM_DETERMINE_COMPANY not working

Hi All,

I am trying to execute this FM - BBP_OM_DETERMINE_COMPANY by entering data from production system.

But I keep on getting the same error "Attribute Company not Found".Is there some issue with the FM or what I need to enter?I just want to see some data,tried entering Logical system field too.

Please let me know what needs to be done.

Thanks.

company.jpg (80.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Apr 17 at 10:44 AM

    Hi,

    Please check in PPOMA_BBP if the user or organizational unit which you use as input parameter for the FM: BBP_OM_DETERMINE_COMPANY has a Company Code (BUK) attribute and there is a company defined in the organizational branch that it is assigned to. I suspect that you execute the FM with a user or org. unit which has no valid company in the organizational branch that is assigned to and that is why you get the error.

    Best regards,

    Daniel

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Daniel,

      Thanks for your reply.I enter the userid to execute the Function module.Also I have checked the Attribute the company code is maintained.

      I tried with at least 10 different users and also with the Partner GUID from table - but000 still the same kind of error.

      Thanks

      screen1.jpg (62.0 kB)
      screen2.jpg (91.5 kB)
  • Apr 23 at 08:35 AM

    Hi,

    Could you please also check if there is a company defined in the organizational branches where the users are assigned?

    Best regards,

    Daniel

    Add comment
    10|10000 characters needed characters exceeded