Skip to Content

GWFND Release upgrade

Hi Experts,

It's quite obvious that SAP_GWFND is associated with NW release however the following not just says upgrade SAP_GWFND to higher release in order to support Push Notifications in Fiori landscape.

Not sure the note is trying to say, upgrade the entire Netweaver stack in order to upgrade SAP_GWFND release or just upgrade SAP_GWFND component release.

One more doubt, what if I want to upgrade SAP_GWFND in ECC system as ECC is associated with netweaver so I hope I need to upgrade entire ECC to upgrade SAP_GWFND ?

Note : https://launchpad.support.sap.com/#/notes/2552233

Thanks,

Pradeep

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Apr 12 at 03:29 PM

    Hi Pradeep,

    The Note is referring to your Fiori frontend system, so the answer to your question depends on whether you have installed Fiori Front-End Server as a hub or an embedded deployment. If it's a hub deployment, meaning you have a separate standalone Fiori frontend that talks to your ECC backend, then that is the SAP_GWFND component that should be updated, and... you're in luck, because the advantage of a standalone hub is that you can upgrade it to the latest and greatest without having to worry about impacts to your entire ECC system, without the full-on intensive testing that an ECC upgrade would entail.

    On the other hand, if you have an embedded deployment, running Fiori frontend installed on top of your ECC system, then you may be a bit stuck. You can update the Support Package level of the SAP_GWFND componet (and SAP_UI) independently of the rest of the NetWeaver stack, but upgrading to a higher release of just these components is riskier. I believe it is possible, just not recommended. One way to find out is to start a Maintenance Planner transaction for the system, with the option "NetWeaver update only" (or something similar to that), and then see. For SAP_UI, at least, it will give you the option of updating to 751 or 752, etc, though it will mark sticking with 750 as recommended, assuming your SAP_BASIS component is 750. I don't recall if it's the same with SAP_GWFND, but it might be. So, in this circumstance, you can give it a try in a sandbox system and see what happens.

    Cheers,
    Matt

    Add comment
    10|10000 characters needed characters exceeded

    • Good answer, some additions from my side:

      You can update SAP_UI independent from your NW release. Please check SAP Note 2431951 for details how to do it. SAP_GWFND instead is bound to the NetWeaver Release installed and cannot be upgraded to a higher release (e.g. no SAP_GWFND 750 on a Netweaver 7.4 system).

      Best regards,

      Sid