Skip to Content
avatar image
Former Member

Alert Rules for ALEAUDIT

I am trying to build Alert Rules for ALEAUDIT Messages coming form SAP R3 to XI. But for some reason it does not work. I see the error category as XIAdapter in SXMB_MONI. I tried different means even selecting No Restriction under Where did the error occur? in Alert Configuration. Anybody tried to do alerts on ALEAUDIT Messages and are successful let me know.

Regards

Mike

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Mar 21, 2006 at 04:48 AM

    Hi micahel,

    A few things you can try.

    To <b>test if your Alert Condifuratio</b>n has been done correctly, in se37, test your alert using the report <b>RSALERTEST.</b>

    If it has been configured properly, correspondingly, email and alert inbox will contain the alert messages.

    Next, go through the note <b>913858</b> on service market place.

    it might solve your problem.

    Regards,

    Bhavesh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 21, 2006 at 05:54 AM

    Micheal,

    What is your current patch level?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 21, 2006 at 06:13 AM

    Hi Michael,

    i think i have already given you this information once.....Anyways go through it again if u have missed it earlier.

    Please check the alert configuration you have done comparing it with what is given in the information provided below....please look at the information provided below in doing the same and see if it helps you solve your problem.

    From SP 14 on PMI-free alerting was introduced. That means before SP 14 one has to configure and activate the End-to-End Monitoring, and to schedule the report SXMSALERT_PROCESS_DATA_GET in order to extract the alerts from the PMI data. For SP 14 and higher, that's not longer necessary.

    If no alerts are being delivered, please check if "Suppress multiple alerts of this rule" is checked for your rule.

    For SP 14 and higher you could also have a look at the report sxmsalert_logreader. This report shows some information about alerts being created or not.

    You'll find more information about trouble shooting the alerting in SAP Note 913858.

    Also just check if this batch program (RSALERTPROC) is running or not.

    The links below on Alert Management (ALM) will be of good help to you:

    Forwarding" target="_blank">http://help.sap.com/saphelp_nw04/helpdata/en/3f/567ddea69d3d4c93a6aedabd08899e/frameset.htm">Forwarding Alerts to Alert Management (ALM)

    Alert" target="_blank">http://help.sap.com/saphelp_nw04/helpdata/en/3f/81023cfa699508e10000000a11402f/frameset.htm">Alert Management

    <a href="/people/michal.krawczyk2/blog/2005/09/09/xi-alerts--step-by-step: Alerts - Step by step</a>

    <a href="/people/michal.krawczyk2/blog/2005/09/09/xi-alerts--troubleshooting-guide: Alerts - Troubleshooting guide</a>

    Meanwhile look at these forum threads also:

    Alerts not getting triggered from Adapter Framework

    Alert Configs...

    Also, In ALRTCATDEF, go to SETTINGS--> CONFIGURATION. By default, the option selected is INTERNAL PROCESSING. Select the option SMTP FORWARDING AS XML and give the email id. This will enable you to send an email alert whenever an error occurs in XI.

    Regards,

    abhy

    Message was edited by: Abhy Thomas

    Add comment
    10|10000 characters needed characters exceeded