Skip to Content

unixodbc web intelligence issue

Hello, world! I am having issues getting a unixODBC connection on the BIP properly querying my data source. Context is trying to use this to source data from Google BigQuery. Here's some system details:

Windows Client and IDT: Working. The 32bit Simba driver connects fine. I can successfully connect to it within the IDT. I can create a UNX, I can see data, everything works fine. I successfully published it to the BIP.

BIP: This is running on RHEL7 for SAP Applications. This is a base installation of the BIP for Linux, 4.2 SP06. It works... for the most part. When I go into WebI and choose my Universe, the fields and metadata come up. When I try to connect to view data, I get a generic pop up message that points me to KB 2054721. Hasn't given me many answers.

When SSHd into the BIP machine, I opened up the webiserver_bobjbip42sp6rhel7.WebIntelligenceProcessingServer_trace.000001.glf file to see what's going on. This error message caught my eye:

<ERROR COMPONENT="WIS" ERRORCODE="10901" ERRORTYPE="USER" MESSAGE="The following database error occurred: [. For information about this
 error, please refer to SAP Knowledge Base Article 2054721 on the SAP Support Portal. (IES 10901)" PREFIX="ERR">
<DEBUGINFO BORESULT="5" FILENAME="kc3cdbtbdacs.cpp" LINEPOSITION="2528" MODULENAME="C3_CS"/>
<REQUESTINFO COMMANDID="0" COMMANDNAME="Validate Update Custom DP" DPID="DP0" DPLONGNAME="" DPNAME=""/>
<REASON>
<CONTENT>
</CONTENT>
</REASON>
</ERROR>
</ERRORS>
 [kctRequestProc.cpp;779]

tracemgr.cpp:358:virtual void TraceManager::Trace::FlushToTrace(const CSTypes::String&, ITraces::Level): TraceLog message 16
|8e0423b6-cb0b-7a29-c7b2-3fe14471381f|2019 04 05 16:06:22:275|-0400|Error| |==|E| |webiserver_bobjbip42sp6rhel7.WebIntelligenceProcessingServer|12024|47238352807680||
 |72|0|2|0|BIlaunchpad.WebApp|bobj-bip-42sp6-rhel7:11327:64.143:1|Webi SDK.CorbaServerImpl.doProcess()|bobj-bip-42sp6-rhel7:11327:64.143:9|webiserver_bobjbip42sp6rhel7.WebIntelligenceProcessingServer.processDPCommandsEx|localhost:12024:-1992481024.1077:1|CiEkvQOG_ULYm5AVa4aCERo8d|||||Administrator||||||ODBCGeneric
 ODBC datasourceJobId:47238540779408ENTER SQLError
                SQLHENV 0x0x2af694673730
                SQLHDBC 0x0x2af694718c10
                SQLHSTMT        0x00000000
                SQLTCHAR *      0x0x2af6893ba3a0
                SQLINTEGER *    0x0x2af6893ba3a8
                SQLTCHAR *      0x0x2af6893ba130
                SQLSMALLINT     513
                SQLSMALLINT *   0x0x2af6893ba3ae

<ERROR COMPONENT="WIS" ERRORCODE="10901" ERRORTYPE="USER" MESSAGE="The following database error occurred: [. For information about this
 error, please refer to SAP Knowledge Base Article 2054721 on the SAP Support Portal. (IES 10901)" PREFIX="ERR">
<DEBUGINFO BORESULT="5" FILENAME="kc3cdbtbdacs.cpp" LINEPOSITION="2528" MODULENAME="C3_CS"/>
<REQUESTINFO COMMANDID="0" COMMANDNAME="Refresh batch" DPID="DP0" DPLONGNAME="Query 1 - BQ Business Layer" DPNAME="Query 1"/>
<REASON>
<CONTENT>
</CONTENT>
</REASON>
</ERROR>
<ERROR COMPONENT="WIS" ERRORCODE="10901" ERRORTYPE="USER" MESSAGE="The following database error occurred: [. For information about this
 error, please refer to SAP Knowledge Base Article 2054721 on the SAP Support Portal. (IES 10901)" PREFIX="ERR">
<DEBUGINFO BORESULT="5" FILENAME="kc3cdbtbdacs.cpp" LINEPOSITION="2528" MODULENAME="C3_CS"/>
<REQUESTINFO COMMANDID="" COMMANDNAME="" DPID="DP0" DPLONGNAME="Query 1 - BQ Business Layer" DPNAME="Query 1"/>

The DSN on the Linux machine is "Google BigQuery 64-bit." I've named it the same thing on the Windows DSN.

The interesting thing is that if I try to connect using the isql tool, it connects perfectly fine.

Does anyone have any suggestions on where else to look to help identify the issue? Thanks!

Add comment
10|10000 characters needed characters exceeded

  • The generic message I get within WebI itself is the following: The following database error occurred: (CS) "Bad Installation : ODBC, Generic ODBC datasource" . For information about this error, please refer to SAP Knowledge Base Article 2054721 on the SAP Support Portal. (IES 10901) (Error: INF )

    webi-error.png (104.7 kB)
  • Get RSS Feed

2 Answers

  • Best Answer
    Apr 18 at 11:04 PM

    Turns out the culprit was a missing character in the odbc.sbo file on the Linux BIP. Slammed my head against this for a while, but it seems to connect for now.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 10 at 10:24 AM

    See Known Issues --> Data Access

    Simba ODBC Network Layer, Bigdata ODBC Connectors do not work on Suse12 and Redhat 7 platforms

    https://help.sap.com/viewer/53bc7eda3cf7470199ce18aa970117cf/4.2.7/en-US/b2d1f4de7d9e4af49e6866bcc4a75db4.html

    Add comment
    10|10000 characters needed characters exceeded