Skip to Content

Upgrading SAP FIORI Front end Server 3.0 to 5.0

We currently have a SAP FIORI Front End server(FES) 3.0, we are planning to upgrade it to FES 5.0. We know that SAP FES 3.0 uses SAP_UI 751 component and SAP FES 5.0 uses SAP_UI 753.

1. Will the SAP FIORI LaunchPad need any configuration changes for it to work in FES 5.0?

2. FES 3.0 works on UI5 version 1.44 and FES 5.0 works on UI5 version 1.60. Should we need to take care about and code changes in our UI5 application?

3. Also what are the manual activities involved while upgrading FES version(like should we activate the UI5 Nodes , ODATA services again in SICF)?

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Apr 10 at 11:01 PM

    Abhilash,

    SAP Note https://launchpad.support.sap.com/#/notes/2217489 covers the upgrade strategy of the FES. For your specific question,

    1),Generally not, but when you implement in a test/development environment, I recommend testing. Most customers do not report issues.

    2) For standard applications, just verify with the Fiori Apps Library that the version of applications you are running show support for Front End Server 5.0. If you have custom apps, you can test them upon upgrade.

    3) The note covers the activities, but for the most part, you would just want to use the steps in https://launchpad.support.sap.com/#/notes/2711925 to update to the latest version of 1.60 and apply any notes referenced as well. Then run follow the cache clearing steps in KBA 2319491

    Tracy

    Add comment
    10|10000 characters needed characters exceeded