Skip to Content

SAP BI 4.2 SP5 SAML SSO Enabled and intermittent 404 missing page error

Hi,

We have configured SAML SSO with Azure AD for SAP BI 4.2 SP5 and we intermittently receive 404 missing page error. The spring_saml_metadata has been downloaded after enabling SSL (entityids have https url). Attached is the screen shot of error message. Please could someone point me in fixing the issue.

Regards,

Avinash

404-missing-page.png

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Mar 25 at 07:01 AM

    Hi,

    Below is a nice step-by-step blog on "Configuring SAML SSO between Azure and SAP BO"

    https://blogs.sap.com/2018/03/01/saml-integration-between-microsoft-azure-portal-and-sap-business-intelligence-platform/

    404 missing page appears for multiple reasons, one of them could be because of policy files.

    Follow below steps.

    Import Java policy files

    Download

    http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html

    Extract zip archive and find there local_policy.jar and US_export_policy.jar

    Replace the existing files found in the “..\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\win64_x64\sapjvm\jre\lib\security” directory with the updated downloaded ones and restart SIA and Tomcat.

    Hope it helps.

    Thanks
    Ashraf

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 22 at 03:01 PM

    see KBA 2604208 BI Auth Troubleshooting Series: SAML Authentication on Tomcat's BOE WebApplication

    enable trace logging KBA 2634421 - How to enable trace logging for BI SAML extension (log4j)

    also, try to enable the SAML Extension Logging, to collect the debugging information.

    see KBA 2634421- How to enable trace logging for BI SAML extension (log4j).

    Add comment
    10|10000 characters needed characters exceeded