Skip to Content

DRF when using with manual filters doesn't filter based on plant

I have scenario in which DRF is being used to transfer the Material mater to ME system. But when i try to use DRFOUT with manual filter in my scenario i am using material,plant as filters. The IDOC generated is not filtered based on the plant instead the IDOC contains all the plants for which the material is available. Could any one suggest any solution ?

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    Mar 29 at 12:43 AM

    Hi Venkata,

    This comes from Replication Configuration in DRFIMG. You need to apply the Filter objects to your Material Outbound Implementation.

    If you material Outbound Implementation is I_MAT, then make sure you include filter objects here.

    Path for this:-

    DRFIMG -> Data Replication -> Enhance Default Settings for Outbound Implementations -> Define Outbound Implementations ( Execute this )

    Select 'I_MAT'. and click on "Assign Segment Filter Objects"

    Make Sure that all the Standard Segment Filters are there, if not, then just configure them.

    Refer the below screenshot

    How it helps.

    Cheers,
    Rohit


    Add comment
    10|10000 characters needed characters exceeded

  • Mar 27 at 12:26 AM

    Hi Venkata,

    Use Segment filters in DRFOUT and not the main filters. Segment filter will restrict the Plant segments based on the filter value.

    Cheers,

    Rohit


    Add comment
    10|10000 characters needed characters exceeded

  • Mar 28 at 05:51 AM

    Thank you for your reply but i am not able to find the segment filters in my case. Is there any settings which i need to make.

    Thanks in advance drff.png


    drff.png (32.2 kB)
    Add comment
    10|10000 characters needed characters exceeded