Skip to Content

CrossTab bottom average not showing from correctly

Hi,

In the attached snapshot the average is not showing correctly as it is taking all values under all date and calculating the average instead of taking crosstab daily average to calculate the final average.

Kindly refer attached snapshot for the problem description and revert with the solution at your earliest.


- Dnyaneshwar

reportsnap1.png (18.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Mar 15 at 06:14 PM

    Hi Dynaneshwar,

    The correct Average should indeed be 2.2, however, if you want to calculate Average of Average, you'd need to use a Calculated member Row.

    -Abhilash

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 15 at 06:32 PM
    Add comment
    10|10000 characters needed characters exceeded

    • Hi Abhilash,

      Could you give a solution in my case as I followed your document but the code is a calculating 1st column?

      In my case, the row shall increase with date (1month date average) and I have more columns also.

      So we need it dynamic check at each column bottom. Refer snapshot of report.

      Thanks & Regards,

      Dnyaneshwar

      snap.png (13.5 kB)
  • Mar 17 at 05:55 AM

    I was at below step but when we insert the insert row to blank row not inserted could please help.

    {

    While in the Preview Mode, right-click the last date and select Calculated Member > Insert Row. Do this until you see three blank rows with zero values.

    }

    Regards,

    Dnyaneshwar

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 18 at 07:45 AM

    Please post the formula you're using to calculate the Average.

    Could you also upload a copy of the .rpt file 'with saved data' to Google drive and post the URL here?

    -Abhilash

    Add comment
    10|10000 characters needed characters exceeded