Skip to Content

Trouble to auth through REST API

Hello,

I'm currently trying to use the BO 4.2 REST API in a project.

Unfortunately, I can't authenticate using credentials. Whatever I try, I'm getting an error in return (FWM 00006) telling me that Active Directory couldn't find my credentials. I tried with a Python script and a javascript script but none of them worked (I tried JSON and XML requests) and I'm forced to use a serialized token which is not what I want. I can log in through the web page without any problem.

Do you know where the problem could come from ? Do I need to encode my credentials in a specific format ?

Thank you for your answer

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Mar 13 at 03:17 PM

    Which version of BOBJ are you running? Is the RESTful Web Service running in the Web Application Container Server (WACS) or has it been deployed to Tomcat (4.2 sp4 and above, I think...)?

    If it's in WACS, and the websites for BOBJ are on a different server than where WACS is running, you need to make sure that the krb5.ini and bcslogin.conf files that are used to enable AD authentication on the web server are also in the C:\windows folder on the server where WACS is running.

    -Dell

    Add comment
    10|10000 characters needed characters exceeded