Skip to Content

GRC PC - Wrong column data for Ad-Hoc Query in Business Rule

Hello GRC community.

If anyone has a solution to the following PC bug/issue, please do share it with me.

Scenario

When doing an Ad-Hoc Query for a business rule in Process Control.

The column names are not reflecting correctly - there is a problem with the custom "Field Descriptions".

Shown below , the data is not the same as reflected in the Data Source.

The output fields when doing the Ad-Hoc Query are as shown below but are not reflected above.

In the Data Source (Object Field Tab), the Fields are pulling through with the correct Field Description, but when running the Ad-Hoc Query

it is not reflecting the Field Descriptions as shown below.

The data is being pulled through from an ERP system to GRC. The necessary plugins have been installed.

System Details

SAP NetWeaver 7.4

GRCFND_A V1100 0013 SAPK-V1113INGRCFNDA GRC Foundation ABAP GRCPINW V1100_731 0014 SAPK-11514INGRCPINW SAP GRC NetWeaver Plug-In

Attempted Solutions

SAP Notes

2355489

2330297

2326942

2321138

2263986

Kind Regards

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Oct 07, 2016 at 12:04 PM

    Hi Ramsundar,

    In many business rule we are facing the same issue, SAP has provided note for some of business rule to run ad hoc query , but mostly Ad hoc query is not working properly for many business rule but its working fine for Data source, please raise SAP oss for the same

    Thanks

    Amit 

    Add comment
    10|10000 characters needed characters exceeded