Skip to Content

ICM_HTTP_CONNECTION_FAILED ERROR

Hi All,

I was trying to create a RFC destination (type H) in sm59 of my XI server for the R3 system. But when i do the test connection it gives me ICM_HTTP_CONNECTION_FAILED ERROR.

Can somebody ellaborate the parameters we need to specify in here.

We have specified, Target host, service number,path prefix /sap/xi/engine?type=receiver in the technical settings and in Logon security provided the relevent details for the R3 system.

Regards,

ShabZ

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Mar 17, 2006 at 07:46 AM

    Is your service activated on your targethost system? Transaction: SICF node ..->sap->xi->engine

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 17, 2006 at 07:54 AM

    Hi,

    have a look at my response from this thread too:

    icmhttpconnectionfailed

    Regards,

    michal

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      We use just /sap/xi/engine/ as our "path prefix". Don't know if that would change things for you.

  • avatar image
    Former Member
    May 17, 2006 at 04:22 PM

    Hi Shabarish,

    Check this -

    1) Path Prefix in SM59 --/sap/xi/engine/?type=receiver and Service No .. (http port)

    Check these SAP Notes -906435,910649,706563

    Hope this helps,

    Regards,

    Moorthy

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 17, 2006 at 04:31 PM

    Shabarish,

    The error message is different if the port is blocked or returns an error. So

    1) Check the following:

    1. Check the following:

    ---Check the audit log of the message in the messaging system according to chapter Error Tracking in the Adapter Engine.

    ---Check the URL that is used to send the message to XI, for example https://server:ICM-port/sap/xi/engine?type=entry

    ---Try to execute the URL in the browser using the user XIAFUSER.

    • Check the error you get:

    o Page cannot be displayed, cannot find server --> server:port

    not accessible

    o HTTP 401 --> unauthorized

    o HTTP 403 --> forbidden

    o HTTP 404 --> Not found

    2) Check the following:

    • Check the outbound binding of the message in transaction

    SXMB_MONI

    • Find the Adapter Engine the message is sent to in the tag SAP:AdapterEngineName --> af.<sid>.<host>

    • Open transaction SXI_CACHE and choose Goto --> AE Cache

    • Check the URL for the Adapter Engine, for example

    https://server:J2EE-port/MessagingSystem/receive/AFW/XI

    • Try to execute the URL in the browser using the user XIISUSER.

    • --> Check the error you get:

    o Page cannot be displayed, cannot find server --> server:port not accessible

    o HTTP 401 --> unauthorized

    o HTTP 403 --> forbidden

    o HTTP 500 --> internal Server Error

    o HTTP 503 --> service not active

    There are different solutions for this:

    a. Page cannot be displayed, cannot find server

    If https is used but you would like to use http, SSL is probably activated by mistake.

    To deactivate the SSL for XI messaging do the following:

    o Open the exchange Profile:

    http://server:port/exchangeProfile

    o Delete the value messaging in the parameter

    com.sap.aii.connect.secure_connections in

    section connections

    o Save it.

    o Restart the J2EE server to activate the change.

    o Restart the message

    b. Page cannot be displayed, cannot find server

    If https is used and you really would like to use https:

    o Check and correct the SSL configuration for the ABAP and

    J2EE sides of the system

    For more information about security in XI see the XI Security Guide.

    c. HTTP 401

    o User XIAFUSER uses a wrong password

    o Check the Exchange Profile and transaction SU01, try to

    reset the password

    o Restart the J2EE Engine to activate changes in the

    Exchange Profile

    d. HTTP 403

    o Path sap/xi/engine not active

    o Activate the service engine in transaction SICF as described

    in the XI Installation Guide

    SAP Exchange Infrastructure Troubleshooting Guide

    56 October 2005

    e. HTTP 404

    o Using the server:port the specified path cannot be found

    o Check that the port really is the ICM HTTP Port (transaction

    SMICM) and not the J2EE port

    o If the port is wrong, change the pipeline URL in the SLD in

    the business system of the Integration Server

    o Restart the J2EE Engine to reset the SLD buffer of the

    Adapter Engine

    2. There may be different solutions:

    a. Page cannot be displayed, cannot find server

    If https is used but you would like to use http SSL is probably

    activated by mistake.

    To deactivate the SSL for XI messaging do the following:

    o Open the exchange Profile:

    http://server:port/exchangeProfile

    o Delete the value messaging in the parameter

    com.sap.aii.connect.secure_connections in the

    section connections

    o Save it.

    o Restart the J2EE server to activate the change.

    o Delete the Adapter Engine cache in transaction SXI_CACHE

    Goto --> Cache

    o Restart the message.

    b. Page cannot be displayed, cannot find server

    If https is used and you really want to use https

    o Check and correct the SSL configuration for the ABAP and

    the J2EE side of the system

    c. HTTP 401

    o User XIISUSER uses a wrong password

    o Check ExchangeProfile and transaction SU01, reset the

    password.

    o Restart the J2EE Engine to activate changes in the

    exchangeProfile.

    o Delete the Adapter Engine cache in transaction SXI_CACHE

    Goto --> Cache

    o Restart the message.

    d. HTTP 403

    o User XIISUSER has no authorization to send messages to

    the messaging system

    o This is caused by a deployment error of the J2EE Engine.

    o Undeploy the component com.sap.aii.af.ms.app and

    redeploy SAPXIAF*.sca.

    o Restart the message.

    e. HTTP 500

    o Internal error in J2EE

    o Check SAP Note 807000

    f. HTTP 503

    J2EE application com.sap.aii.af.ms.app not active

    SAP Exchange Infrastructure Troubleshooting Guide

    October 2005 57

    o Try to (re)start the application using the Visual Administrator

    Choose Server --> Services --> Deploy --> View on Application

    or restart the J2EE engine

    Regards,

    ---Satish

    Add comment
    10|10000 characters needed characters exceeded