Skip to Content
0
Sep 29, 2016 at 02:48 AM

SUM Error updating Solman Java Stack for SP03

115 Views

Hi All!

I'm just wondering if anyone has had this issue I am facing while updating the Java Stack of solman 7.2 to SP3 using SUM, I have been searching around but I can't seem to find any clues or direction for this error.

The error is:

An error occured during the execution of Import CR-SDA Models of action execute.

Service com.sap.sdt.j2ee.services.servicesimpl.CRSDAModelService failed with the following message:

(Trouble Ticket)

java.lang.NoSuchFieldError: C_SAP_InstalledSystemLicense

For more information, see the log file D:\SP3_JAVA\SUM\sdt\log\SUM\IMPORT-CR-SDA-MODELS_01.LOG.

Use the provided information to troubleshoot the problem. There might be a SAP note providing a solution to this problem. Search the SAP notes using the following search terms:

SUM,execute,component-deploy-710,import-cr-sda-models,com.sap.sdt.j2ee.services.servicesimpl.CRSDAModelService,class java.lang.NoSuchFieldError

(IMPORT-CR-SDA-MODELS_01.LOG)

I checked the log:

<!--LOGHEADER[START]/-->

<!--HELP[Manual modification of the header may cause parsing problem!]/-->

<!--LOGGINGVERSION[2.0.7.1006]/-->

<!--NAME[D:\SP3_JAVA\SUM\sdt\log\SUM\IMPORT-CR-SDA-MODELS_01.LOG]/-->

<!--PATTERN[IMPORT-CR-SDA-MODELS_01.LOG]/-->

<!--FORMATTER[com.sap.tc.logging.TraceFormatter(%d [%6s]: %m)]/-->

<!--ENCODING[UTF8]/-->

<!--LOGHEADER[END]/-->

Sep 28, 2016 4:55:03 PM [Info ]: About to process archive D:/SP3_JAVA/LMMODELNW12_0-20009684.SCA. The CR-SDA content will be extracted first.

Sep 28, 2016 4:55:03 PM [Info ]: About to import archive D:\SP3_JAVA\SUM\sdt\tmp\sap.com~product~lm-model-nw.sda.

Sep 28, 2016 4:55:45 PM [Error ]: The following problem has occurred during step execution: java.lang.NoSuchFieldError: C_SAP_InstalledSystemLicense.

There's not much more logs, I thought it might be something to do with the CIM models, but that's already updated to the latest, I tried retrying(because that worked in some scenarios in past SUM updates) but to no avail this time. Can't really find much more logs than this. I've raised an SAP message, but in the meantime, perhaps one of you already have a solution? 😊

Cheers!

Chris