Skip to Content

icmhttph.log file is not being created

Hello experts,

we have found a problem with icmhttph.log file is not being created on some of our systems. We have profile parameter icm/HTTP/logging_0 set to

PREFIX=/, LOGFILE=icmhttph.log, FILTER=SAPSMD, LOGFORMAT=SAPSMD2, MAXSIZEKB=10240,FILEWRAP=on, SWITCHTF=month (according to documentation in managed system configuration), I have also tried PREFIX=/, LOGFORMAT=SAPSMD, LOGFILE=icmhttp.log, MAXSIZEKB=10240, SWITCHTF=day, FILEWRAP=on (from note 1252944). Then obviously I have restarted ICM in SMICM, I can also see in SMICM that parameters are set in SMICM->Parameters->Display. Self diagnosis in Solution Manager tells us to follow note 1252944, which does not work. If I create log file manually under the user <SID>adm and if I test /SDF/READ_HTTP_LOG_INST log file is retrieved from OS level.


Problem is, that this problem has started to occur just recently, we have updated our ST-PI and A/PI components, applied some solman notes and patched servers before, but I can say if this can be reason, because the problem occurred just on some systems and not at once.


We are running SM 7.1 SP14, this particular managed system is SAP ECC 6.0, kernel 721/600, with solman components ST-PI 2008_1_700 SP14 and ST-A/PI 01S_700 SP1 running on HP-UX.


Thank you for every help,

sincerely Jan




Systems.png (47.8 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Sep 15, 2016 at 08:10 AM

    Hello Ján Valentiny,

    Please apply this note - Apply SAP Note 2057787 to SAP Solution Manager system. This should fix your issue.

    Reference KBA: https://launchpad.support.sap.com/#/notes/2171850/E

    you may also want to refer this page Missing_HTTP_log - Technical Operations - SCN Wiki

    Feel free to revert.

    Regards,

    Ragu

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 15, 2016 at 10:36 PM

    Hi Jan,

    Please check below SAP Note and cross check your configuration:

    1252944 - E2E Trace: Problem retrieving data from managed system



    Thanks,

    Manish

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello Manish,

      thank you for your reply.

      Speaking about note 1252944, unfortunately nothing from part 1b, does apply to our issue. I have also tried SU53 and SM20 check and there is no problem.

      Also. the same message in self diagnostic (ICM HTTP Log from system PHR00001 cannot be retrieved. Reason: Execution of /SDF/READ_HTTP_LOG_INST ...) occurred on another system and I can see logfile on OS level. If I test call function module /SDF/READ_HTTP_LOG_INST with user (copy of our RFC destination read user with assigned SE37) I got all results.

      Regards,

      Jan

      sdfsmde2e.png (13.6 kB)
  • Posted on Sep 16, 2016 at 11:01 AM

    Hi Ján,

    Check if note 2309642 - Collective corrections as of ST-PI 2008_1 SP14 and ST-PI 7.40 SP04 helps or not.

    Regards,

    Ning

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.