Skip to Content

S4HANA Virtualization Error (Cannot find startdb)

Hi.

Our system is:

SLES 11 SP4

S4HANA OP 1511

Has anyone virtualized S4HANA?  I have successfully installed S4HANA the original VMs works perfectly.  With the original system I follow these steps.

First, I startup the HANADB

  1. login as root
  2. Navigate to: /usr/sap/hostctrl/exe/
  3. Execute: ./sapcontrol -nr <instance number> -function Start


Second, we start up the application server

  1. login as <sid>adm
  2. Execute: sapstart all

However, When I try to start up a cloned system I can't start the application server.  I get the following errors:

To troubleshoot I have looked at the following so far:

  • I noticed the ethernet controllers was weird because there was already a VM with the same IP.  I deleted and reset the ethernet controllers and still get the same error as above.  I also try to use "startsap hostname" and get the same error.
  • I have also tried to manually set 192.168.1.xxx to hostname.example.com in the etc/host file.  I still get the same error.
StartupError.png (35.2 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Sep 19, 2016 at 02:17 AM

    Hi,

    Is it possible to share the trc file

    also check if the below two commands show correct values

    hostname

    hostname -f

    Are DB and Application running on the same server?

    From the error, first obvious thing I can deduce is that, it can't find the "startdb" command, mountpoint? ping if on another VM? did you try these things?

    Best Regards,

    Bharath

    Please mark either as helpful or answered if this message helped you in resolving the issue. 😊

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 06, 2016 at 07:51 AM

    Hi,

    First of all, make sure your HANA DB is actually up and running without error, the command sap control -nr <insatnce_number> StartSystem HDB only send the start command to sapstartsrv program, it doesn't guarantee you the system will get started if there's something wrong, you can check the HANA instance by using the following command:

    sapcontrol -nr <instance_number> -function GetSystemInstanceList

    sapcontrol -nr <instance_number> -function GetProcessList

    If any of result is not GREEN, then your HANA isn't running well. You can check the trace log files at the following location

    /usr/sap/<SID>/HDBxx/<hostname>/trace

    If your HANA runs without problem, then I suggest you to run the following command and check the log file at the S/4HANA Instance server with <sid>add user. Share the log file here to help us better understand your problem.

    R3trans -d

    Regards,

    Michael

    Add comment
    10|10000 characters needed characters exceeded