Skip to Content
0

LDAP to IDM synch job keeps running

Feb 09, 2017 at 03:14 PM

148

avatar image
Former Member

Hi Experts,

I'm using IDM version 7.20.9.16-SQL-2015-05-28

I trapped to a strange situation while running a job in IDM, to sync LDAP-IDM Data.

I successfully ran this job earlier. As to Read LDAP pass it use to take 3hours of time, i have made few changes(Filter) into LDAP URL under Read LDAP pass and then i ran same job. The I navigated to Status under same folder, so the job state keep on Running and Progress show 0 Records and after 5 minutes it automatically schedule same job after 10 seconds and then it starts again with no Records. It happened in same for an hour & then I Stopped the job. After the job stopped, I ran the same job again & unfortunately same result. Finally it goes into Error state

Then i reverted the Read LDAP pass to the original but even that didn't helped out.

I ran another job to sync LDAP to IDM which i usually use for testing with same configuration and same dispatcher & it ran successfully with in same IC.

Any idea how to resolve this one. Before deleting & configuring again thought to check in SDN.

Attached are the status of the job

*Revision*

Here are the debug result - I'm using following passes in Job

While I run with only "Clear Temporary Tables" Enable,it Run successfully. Then I ran with only "ReadGroupOfUniqueNamesFromLdap" Enabled & all other disabled,it too ran Successfully. However when I ran with only "ReadUsersFromLdap" Enable & all other disabled...It is not reading any records. So I interpret issue is with Read User pass but Connection and all are fine. The same pass I'm using in my Dev system which is running successfully. Here is the pass details:

Read User LDAP URL is almost similar to Read LDAP Groups(Only difference is the path where SAP Groups exist in LDAP and SAP Users exist in LDAP)

idm1.png (1.9 kB)
idm2.png (1.7 kB)
pass.png (13.8 kB)
job1.png (52.5 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Jaya Kumar Feb 10, 2017 at 10:28 AM
0

Hi Ravi,

Can you please share more information, passes and job log.

Regards,

Jay

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Feb 10, 2017 at 10:57 AM
0

There is no Job Log, because Job has went into some loop.....

As I have to Force Stop it by clicking in

I have used standard passes for "LDAP (ADS) - Delta Load(Custom)"


idm.png (2.6 kB)
Share
10 |10000 characters needed characters left characters exceeded
Matt Pollicove
Feb 10, 2017 at 01:56 PM
0

Hi Ravi,

What are you syncing from? AD, a virtual directory, something else? Are you using SSL or any other security features? How long have you let it run? Has an actual time out or other error occurred?

Thanks,

Matt

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

I'm syncing from AD.

Job is running for around 5 minutes and when job receives no data, it goes on idle state and reschedule it after another 5 seconds and this goes on until I disable the job and stop it. After the job stops it shows in error state till I Enable it & re-run the job. Once i re-run the job I'm facing same issue.

One more strange things I noticed while I'm executing any IDM table query marking * it is taking much time, whereas it was never the case before.

For query - select * from idmv_vallink_basic it gave me result however the query is keep on executing unless I stop the query. Please have a look in below screen which I ran for around 7minutes.

For query - select * from idmv_link_ext it doesn't give me any result & keeps on Executing query until I stop it. Please have a look in below screen which I ran for around 7minutes.

I'm using table idmv_link_ext in "DeleteUserToGroupAssignments" pass & "DeleteUserToRoleAssignments" pass. I doubt this might be the reason.

idm.png (124.5 kB)
idm1.png (59.3 kB)
0
Steffi Warnecke
Feb 13, 2017 at 10:50 AM
0

Hello Ravi,

are we talking about a big number of results here for your query?

.

Your issue reminds me of the trouble we had with one of our jobs for the database migration. It would run and run and run and if I checked it, it would then stop and re-schedule. So we got nowhere.

Then we changed the java heap space on the dispatcher we used for it and finally it ran successfully. We didn't have those issues with the test system, just the prod.

So check the settings on the dispatcher you are using for this job. Depending on how much RAM your IDM server packs, you can set the "Java options" on the "Policy tab" for the dispatcher and see where this leads you.

.

Regards,

Steffi.

Show 3 Share
10 |10000 characters needed characters left characters exceeded

As a further point to this, is the bootstrap option still avialable?

0
Former Member

No, it isn't big number there are around 1200 users...I have same number of users in Dev when i compare to Prod IDM but When i run same query in Dev it give me result with in 10 seconds whereas in Prod it keeps on executing.

I'm not sure, as query - "select * from idmv_link_ext " is going in loop and due to this reason my Job isn't running or something else :(

As i'm using table idmv_link_ext for "DeleteUserToRoleAssignments" pass under that Job I doubt this might be the reason. This Pass is perfectly working in Dev IDM only issue with Prod IDM.

0

Hello Ravi,

There could be two probable reason for such issues -

  • Data Issue - The data which you are getting from AD might be corrupt.
  • Job Issue - May be some job linkage has been broken which lead to such issue.

I would recommend to import your IDM-AD sync job from IDM PRD to IDM Dev environment and try to re-run the job and confirm whether you are still getting the same issue. It will help you to determine what is the actual reason for such errors. Once it will be investigated, we can easily fix it or can easily find alternatives.

Could you please explain how you are using table idmv_link_ext for "DeleteUserToRoleAssignments" pass and where you are using this pass. Source and Destination screenshot of the task would be more helpful to investigate your issue.

Regards,

C Kumar

0
avatar image
Former Member Feb 15, 2017 at 04:15 AM
0

Any advice?

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Matt and I gave some advice and ideas, but have not heard back from you concerning those:

  • Check dispatcher
  • Check java options on dispatcher
  • Bootstrap option on job

.

Regards,

Steffi.

0
Former Member
Steffi Warnecke

Sorry for delayed response, I met with an accident :(

Here is the screenshot for these 3 points:

Also I have revised the actual issue. Kindly follow the revision

dispatcher-1.png (10.0 kB)
dispatcher-2.png (9.5 kB)
job.png (10.9 kB)
0