Skip to Content

Setting SAP CPS CMD parameters in CMD code

Hello experts! I'm trying to set a CMD job parameter from the code using the SET statement but it just does not work although it doesn't send an error, the code should be something like this:

SET Answer="Hello World!"

This kind of code works normally using SAP BPA 9.0 but it just doesn't work in SAP CPS 8 I wonder if i'm using the wrong sintax or if there is something speciall I have to configure in the job to make this work.

I hope you can help me with this

Thank you very much

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Sep 06, 2016 at 06:50 AM

    Hi Leonardo,

    What I frequently forget is to select the correct parameter direction, as in, the default is "In", however, here you want either "In/Out" or "Out". Can you double-check that for me.

    As Gerben pointed-out, it might also be a bug, it would help if you could provide us with the exact release of version 8 you are using.

    Regards,

    HP

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 06, 2016 at 06:37 AM

    Hello,

    This might have been a bug in the CPS version you are running. You can also try:

    Answer="Hello World!"

    So without the SET


    Regards Gerben

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.