Skip to Content
author's profile photo Former Member
Former Member

Stored Procedure Called through Crystal Report, Doesn't insert records

Dear Tech Team,

I have a RPT file that has few sub reports. The Main Stored procedure that I'm using for the crystal reports inserts few records in one of the table and that table is referenced in the sub reports. This works fine with the old version of crystal reports (Version 9) with the C++ Code. We recently migrated it to .Net Version: SP16, VS2013, MS SQL Standard 2014. It appears that when the main Stored Procedure is called, which has the insert statement to insert records in another table not at all works. We use ODBC Connection (SQL Native Client) to connect to the SQL server. Please advise.

Thanks,

Arun

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Aug 30, 2016 at 10:09 PM

    Try using the SQL Native 10/11 client.

    If you turn on SQL Profiler are you see the SP run and inserting data?

    Could b e SQL Or CR is caching the data, make sure you are committing the Data also.

    You may also need to enable Dirty Reads so it captures the data in the buffer.

    Do more debugging, lots of DB security and other changes since CR 9.

    Don

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.