Skip to Content

Unable to select any data (see long text)

Hi,

I am experiencing a strange behavior in the SPL functionality.

What I have done so far:

  • I have created a legal regulation ZSLEU and a list type DPLEU activated on country level (DE, import/export incl. domestic) and on country group level (CNTRYGR_AL (the standard group with all countries of the world), import/export incl. domestic)
  • Went through all other customizing steps as described in the configuration guide
  • I have created some SPL entries for testing purposes
  • Generated comparison terms, aggregated the comparison terms and generated comparison terms for business partners (all partner addresses). No errors here.

If I am simulating a general address screening (/SAPSLL/SPL_CHSS3) for ZSLEU I am able to get a positive hit based on my search term and the expected screen showing the SPL results.

If I am simulating a business partner address screening (/SAPSLL/SPL_CHSS1) I am getting the error message “Unable to select any data (see long text)”. The same is happening in /SAPSLL/SPL_CHSS2 (simulate document address check).

Did some research and was not able to find anything helpful. So I did some debugging (keeping in mind, that I am no programmer and know basically nothing about ABAP).

Nevertheless, I think I was able to find out that at some point GTS tries to get a legal regulation which is not working. (et_leglrgi is still in an initial state, which is obviously wrong at this point) (see screenshot).

Here I am stuck, since I cannot really interpret the coding.

Did someone of you experienced this before? Any ideas?

Best regards

Marco

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Aug 25, 2016 at 09:30 PM

    Hi Marco,

    I'm not really familiar with this area of the system, but from a quick look at the code, I get the idea that the "Exclude Expired Addresses" flag in the Legal Regulation might be involved here.

    If that flag is set in your Legal Regulation 'ZSLEU', perhaps you could try "unsetting" it, and re-try the screening?

    Hope that helps.

    Regards,

    Dave

    Add comment
    10|10000 characters needed characters exceeded