Skip to Content
author's profile photo Former Member
Former Member

ODATA Service exposed by Custom CDS View not showing Entity Set

Hello All,

I Have created one custom CDS and teh corresponding Odata Service has been added in Gateway through T Code - /iwfnd/maint_service and metadata has been loaded successfully. Now, when I try to Create KPI using KPI Design in Fiori Launchpad, I am getting my Custom CDS View and Odata Service but When I try to fetch corresponding EntitySet its shows "No Data".Then I manually write the entity set, on selecting the value measure I get the popup failed to load metadata.

When I try to fetch Odata Servie the metadata uri has no extention "/EntitySets" because of which I think it is not fetching entity sets. Could you please advice how to rectify.

Uri :

uri:"https://XXXXXX/sap/opu/odata/iwfnd/catalogservice;v=2/ServiceCollection('ZMONTH_INVENTORY_CDS_0001')"



Thanks


Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Sep 16, 2016 at 12:46 PM

    Same issue here on SAP_ABA 75A SP0003. Suggestions appreciated.

    (Although my current clarification differs a bit from the one Yogendra Ahuja is giving.)

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.