Skip to Content
avatar image
Former Member

Resource not found for segment 'C_PurchaseOrderFsType'

Hello,

I was implementing the SAP Fiori apps "My Inbox - Approve Purchase Order" and it was successful( Tile was shown, Have items counter, Can be opened ). But when i tried to see the detail of the Purchase order, it just showed nothing and the console display error which
has the message like the picture below.

The Purchase Requisition is working fine and the software component 'UIX01CA1' has been upgraded to SP02.

Please kindly share how to solve this problem.

Thank you,

Sittisak C.

Error.png (89.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Aug 25, 2016 at 05:34 AM

    Can you share the error log?


    tcode: /iwfnd/error_log

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 25, 2016 at 04:30 PM

    Hello,

    We have the exact same error, for the exact same Fiori Application , and exact same symptoms

    for "My Inbox - Approve Purchase Order"


    Here is the error :

    "My Inbox - Approve Purchase Order"


    "error" : {

        "code" : "/IWFND/CM_MGW/051",

        "message" : {

          "lang" : "en",

          "value" : "Resource not found for the segment 'C_PurchaseOrderFs'"

        },

        "innererror" : {

          "application" : {

            "component_id" : "MM-PUR-PO",

            "service_namespace" : "/SAP/",

            "service_id" : "C_PURCHASEORDER_FS_SRV",

            "service_version" : "0001"

          },

          "transactionid" : "57B3D0DDC7553167E10000000A473765",

          "timestamp" : "20160825161257.4243350",

          "Error_Resolution" : {

            "SAP_Transaction" : "Run transaction /IWFND/ERROR_LOG on SAP Gateway hub system and search for entries with the timestamp above for more details",

            "SAP_Note" : "See SAP Note 1797736 for error analysis (https://service.sap.com/sap/support/notes/1797736)",

            "Batch_SAP_Note" : "See SAP Note 1869434 for details about working with $batch (https://service.sap.com/sap/support/notes/1869434)"

          },

          "errordetails" : [

          ]

        }

      }

    }



    ..ERROR_INFO No system alias assigned to user 'user' service 'ZC_PURCHASEORDER_FS_SRV_0001' and SID 'HAN' CNT '200'

    Service is correctly configured :

    Alias is assigned , SICF service is active .....

    I emptied the caches mutiples times, deleted and reactivated the service, ... did not help

    Really do not understand.

    Thank you for any hint you might have

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Santiago,

      Were you able to fix this no display issue, I am having the same issue and have tried all the below steps, but not able to fix the issue..

      SNotes

      1. 0002322131 My Inbox 2.0 SP02 Patch (2.1.4)
      2. 0002348555 My Inbox 2.0 SP2 Patch (2.1.7)

      Transactions

      1. /IWFND/CACHE_CLEANUP
      2. /IWBEP/CACHE_CLEANUP

      Reports :

      1. /UI2/DELETE_CACHE_AFTER_IMP
      2. /UI2/INVALIDATE_GLOBAL_CACHES
      3. /UI2/CHIP_SYNCHRONIZE_CACHE

      Regards

      Praveen