Skip to Content
author's profile photo Former Member
Former Member

Problem with SecurityAdmin role after SPS 11 upgrade

Dear Colleagues,

After SPS 11 upgrade, I realized that the system role "sap.hana.xs.ide.roles::SecurityAdmin" has been turned into a blank role. It no longer contains SYSTEM and OBJECT PRIVILEGES. Now it is an almost empty role.

Please, anyone could tell why this is happening and how it can be solved to be a functional role again?

Before the upgrade, it worked OK and it has SYSTEM and OBJECT PRIVILEGES.

Thanks a lot!

Kevin Olesker

Argentina

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on Aug 22, 2016 at 04:01 PM

    Hello Kevin,

    the role should work as before, because role "sap.hana.ide.roles:SecurityAdmin" (without "xs" in the name) is granted to the role. Due to a reorganization already with SPS09 the new role was introduced and the old role was adjusted.

    Regards,

    Florian

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.