Skip to Content
author's profile photo Former Member
Former Member

Report parameter not display in full in Crystal Report Server 2013 - where is the web.config file?

Hi,

We have some reports published on Crystal Report Server 2013 that is using dynamic parameter. However, it is not showing the full list in the dynamic parameter.

I found the post that suggest to make changes to web.config and app.config . As they are using Tomcat, I think the file I need to change is Web.xml. However, I cannot find the right file that contains the following, which I thought I should find and simply amend the value for maxNumberListOfValues

<configSections>

<sectionGroup name="businessObjects">

<sectionGroup name="crystalReports">

<section name="crystalReportViewer" type="System.Configuration.NameValueSectionHandler" />

</sectionGroup>

</sectionGroup>

</configSections>

<businessObjects>

<crystalReports>

<crystalReportViewer>

<add key="maxNumberListOfValues" value="50"/>

</crystalReportViewer>

</crystalReports>

</businessObjects>

On the older version, I know I can find it in C:\Program Files\Business Objects\Tomcat55\webapp

However, what is the new location in Crystal Report Server 2013 and which file should I change?

Appreciate some help here.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Aug 22, 2016 at 01:57 PM

    I think the config files are a solution when you're running in a .NET application - not necessarily for Crystal Reports Server (CRS).

    Assuming that you're using "classic" Crystal reports and not Crystal for Enterprise, here's what I would do instead:

    1. Log in to the CMC.

    2. Go to Servers.

    3. Go to the properties of the CrystalReports2013ReportApplicationServer.

    4. Change the "Browse Data Size (records):" property - increase the value so that it is more than the number of records you expect to see in any dynamic parameter.

    5. Change the "Number of database records to read when previewing or refreshing a report (-1 for unlimited):" to -1.

    6. Save and Close.

    7. Go to the properties of the CrystalReports2013ProcessingServer.

    8. Change the "Number of database records to read when previewing or refreshing a report (-1 for unlimited):" to -1.

    9. Save and Close.

    10. Stop and then start both the CrystalReports2013ReportApplicationServer and the CrystalReports2013ProcessingServer.

    -Dell

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Dell,

      Thanks for replying. I found the problem was because the customer did not add the MaxRowsetRecords key in the registry on the Server although they have been advised that should be the place to do it, not local workstation.

      Your reply did teach me some new information. So, thanks for sharing.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.