Skip to Content

Row delimiter was seen for R3_DF

Hi All,

I am getting below error from an ABAP DF, all help is appreciated.

|Data flow DF|Reader R3_DF

A column delimiter was seen after column number <2> for row number <3102683> in file </xxxx.dat>.

The total number of columns defined is <2>, so a row delimiter should be seen after column number <2>. Check the file for bad

Thanks

Sam

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Aug 20, 2016 at 10:58 AM

    If ABAP is preloaded then check the ABAP program in your SAP ECC and check how many columns are defined in the program to how many columsn are the in the ABAP dataflow.

    The job is expecting only 2 columns in the dataflow but the columns defined are 3 in the program. Also please check if there is any bad data in the .data file generated by ABAP like any of the data contains the delimiter.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 22, 2016 at 01:47 PM

    Hi ,

    Go to Formats--> flat files -->go to your flat file-->edit-->select Adaptable schema as YES and row delimiters with different combinations like Tab,semicolon,space,comma,~.

    I think this will work as it worked for me.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 23, 2016 at 07:57 AM

    Hi SPK,

    This issue is actually caused by the non-printable(most probably due to CRLF i.e. Carriage return and Line Feed) characters getting added in the data which occupy a space for a column. As a result, our data does not get mapped perfectly to the columns and the leftover data looks for a column to map but doesn't get any. Hence, the error.

    Open your dataset using different editors like notepad or MS WORD(turn on Show/Hide) and have a closer look at the data, you'll find the affected row.

    Look for a mechanism to eliminate unwanted data(eliminating at the Source would be the best deal).

    Regards- Santosh G.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.