Skip to Content
Former Member
Aug 19, 2016 at 12:39 PM

Adaptive Job Server - Schedules stuck at pending



Server environment:

AIX64 6.1 TL9

SAP BO BI Platform 4.1 SP8 P1 Enterprise - migrated data from 3.1 system

SAP Data Services 4.2 SP7 - migrated data from 3.2 system

Tomcat 7 - BI webapps


When i schedule anything it is stuck on pending, webi report, search index schedule or monitoring probes.

During the pending state Adaprive Job Server produces a dump log every few seconds until I pause or delete scheduled instance.

The error I get in the log dump is SIGSEGV ... accessing faulting address ... Problematic frame:# C [] (i attached log)

I have attached AIX log during that period, here is one line from log:

Aug 18 13:00:33 tae1rds1 user:err|error boe_jobsd[16842822]: Subprocess (Job Server Child) could not be started. Reason: Couldn't get IJob interface or writing IAudit: Pipe exception. Reason: boe_jobcd (, 2, Could not send request to child [20775032] (timeout = [120000]ms, request time span = [5098]) .

The error is not because of email as a destination. it is the same when i schedule to BI inbox. The SAP Note 2303169 doesn't solve the problem.

I've put –type OUTPROC –forceterminate –RequestTimeout 36000000 at the end of AJS parameters with no help.

I have also stopped or paused all platform search, auditinig, monitorin and webi schedules and tried to run only one report schedule with the same result.

I have contacted the SAP support and the latest development is that I maybe have C++ redist too high. I have vc++ 13 on AIX, SAP PAM says I need 10. I thought they were backwards compatible.

Please help,

Ivan Rubil