Skip to Content
author's profile photo Former Member
Former Member

SAP HANA CLIENT and Visual Studio 2015

  1. I downloaded SAP HANA CLIENT package and installed it according to the documentation (HDB_CLIENT_WINDOWS_X86_64).
  2. I am trying to add a connection to HANA database in Visual Studio 2015 Community however I am not able to choose Microsoft .NET Framework Data Provider for SAP HANA to create a data connection - there is no such option - database provider is missing.
  3. According to the documentation - client package works with VS 2010 and later.
  4. After I installed client software I got the following message: "Installing HANA ADO.NET for Visual Studio 2010..... Succeeded."
  5. I installed Visual Studio 2010 on different host (clean installation) and had to modify some registry keys according to this article - Registering Missing Data Providers with Visual Studio 2012 | blog.nwoolls.com - to make it work. Finally it does but after these modifications.
  6. It would be weird if Client Package worked for older version of VS with Entity Framework 6 and did not work with the MS's latest product - i tried adding the same registry keys almost everywhere in the registry where DataProviders and DataSources keys are present in terms of Visual Studio.
  7. I tried modyfing machine.config (Framework64 folder), denenv.exe.config - almost anything I found in the net.
  8. I installed CData's SAP db provider (3rd party) yesterday and it worked like a charm when it came to display db provider in the list of providers (when trying to define a connection in VS 2015).

I've been spending 3 days trying to find the solution - I would be grateful for any help.

db_provider.jpg (73.7 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Aug 22, 2016 at 01:16 PM

    [WORKAROUND]

    1. I used VS 2010, VS 2012, VS 2013 uninstallers to get rid off files which would suggest to SAP HANA CLIENT installer different version of VS than the one currently installed.

    2. I had previously VS 2013 installed but I changed it to VS 2015 Community - long time ago.

    3. Somehow SAP HANA CLIENT installer was trying to deploy db providers for VS 2010 - which is even more weird (why not VS 2013?).

    4. Anyway I had installed VS 2013 Community anew yesterday (next to currently installed VS 2015 Community) and then once again I installed SAP HANA CLIENT - this time I got no information that db providers for VS 2010 had just been installed - there was simple "Succeeded" (no VS version info like it was last time).

    5. I launched VS 2013 Community and finally when tried to create a new data connection I could notice SAP HANA - success.

    I opened my VS 2015 Community project in VS 2013 Community and we will see if I can carry on my work with older version of VS.

    It seems that SAP HANA CLIENT installer does not recognize version of VS currently installed in Windows properly. It installed db providers for VS 2010 whereas I had never that version installed in my system (maybe VS 2013, or VS 2015 or any other software related installers added VS 2010 related files or registry keys during installations - however CDATA's SAP db provider recognized properly my VS 2015 Community).

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.