Skip to Content

Add button not visible in a different WCV

Hello Everyone,

The requirement is to have QualityNotification (QN) as a Workcenter and have Actions as a Facet in the QN TI view .

And on click of the Actions Facet, should display allthe Actions with an option to add a new Action as well.

What I have done:

1. I have added a tab in the QN.TI and added the Add Button to the AdvancedListPane.

2. In the QN_WCView > Properties > RBAMData > Assigned Objects - added all the Actions related views

3. Missing Add Button in the browser view

4. Error in the Studio Preview on click of the preview but the button appears here

I'm not sure what is wrong here, I request support to understand what is wrong here.

Thanks

Gayathri.R

pastedImage_2.png (235.2 kB)
pastedImage_3.png (237.7 kB)
pastedImage_4.png (36.8 kB)
pastedImage_5.png (38.7 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    Posted on Aug 23, 2016 at 05:16 AM

    Hi All,

    The issue got resolved. :-)

    Identified the problem was because the data list i have created did not had the TT assigned to it. Shared snapshots here ...

    Add button configured to refer Data list > Action ID

    Thanks

    Gayathri.R


    pastedImage_0.png (75.0 kB)
    pastedImage_1.png (131.5 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 18, 2016 at 05:22 PM

    Dear Gayathri.

    Usually you get this error message when you are not authorized to access UI application (...) .

    This error message appears when Business Role is not assigned to the user.

    To check the business role assignment please follow the below steps :-

    • Login with the User with which you are getting this error message.
    • Go to Application & User Management Work center.
    • Go to User & Access Management view.
    • Go to Business users & Find the User.
    • Click on Edit & then Select Access rights.
    • Go to Business Role Assignment.
    • Select the checkbox under Assigned to user for the Business Role Name Generic.

    Please check this, it might help you.

    Regard

    Anant

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 22, 2016 at 07:20 AM

    I identified a change today, Instead of QuickCreate I tried to set an onclick Event handler - As Action Event handler to add a Row.

    Strangely I found that the Add button appeared.

    And on click of Add, it tries to add a row ...

    So i understand, the problem is only when I change it as QuickCreate.

    Please support me if you have encountered similar issues


    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.