Skip to Content
0

DBACOCKPIT: SQL30082N Security processing failed with reason 17 (after system refresh)

Feb 09, 2017 at 10:28 AM

30

avatar image
Former Member

Hi all

We have carried out a system refresh (import/export via SWPM) to a new system BWS and accidentally entered the wrong password for DB2BWS when first running DBACOCKPIT.

We then went into transaction DBCO and corrected it, but DBACOCKPIT is still returning the same error: SQL30082N Security processing failed with reason 17

We have already followed the steps in:

1846362 - SQL30082N Security processing failed with reason "17" &

1791728 - DBACOCKPIT requires password

These do not help. We have tried removing the entries in DBCO and in DBACOCKPIT and starting again but DBACOCKPIT always displays the error. Please note that DBACOCKPIT is also no longer prompting for a username/password, like it did the first time (even if the DBCO entry has been deleted).

We are certain this is the correct password, we have used it to log on with the user. We also tried a different password (shorter, no special characters) and this made no change.

We also ran the latest version of db6_update_db.sh as per:

1365982 - DB6: Current "db6_update_db/db6_update_client" script (V58)

This made no difference.

One thing odd I've noticed... in SE16 when you look at table DBCON the password shows as an encrypted value (i.e. random characters) - but in all of our other systems (where everything is working as it should) if you look then the password entry looks blank. We tried entering a blank value but it doesn't accept this. Odd, as the following link seems to suggest that you can: https://help.sap.com/saphelp_crm50/helpdata/en/9c/d736b880c34f76b507bac7751a0474/content.htm
Pretty sure when we've had an incorrect password before we've maintained it in DBCO though and it all worked fine.

So why isn't it working here?

Thanks
Ross

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

avatar image
Former Member Feb 09, 2017 at 01:46 PM
0

My colleague fixed this:

-seems to be a bug in DBCO not saving the password property (in SE16, DBCON showed a random string of characters - shouldn't show anything)

-fix is to click the icon in top left corner of DBACOCKPIT to enter full screen mode, goto DB connections, and then click 'change user credentials'; you can then enter the correct password and it's saved correctly and connects.

Share
10 |10000 characters needed characters left characters exceeded