Skip to Content
author's profile photo Former Member
Former Member

New Interface created PI not visible in SPROXY ECC

Hello experts,

We have created a new interface (SOAP to PROXY) in SAP PI, we have done local configuration testing and found the configuration to be correct in ID.

However when we open sproxy in ECC to generate proxy class, we found only old interface available in sproxy, we are unable to see our newly created interface.

Any inputs and pointers are most welcome 😊

Regards,

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Aug 10, 2016 at 12:41 PM

    Thanks guys for ur responses... 😀

    The issue was with RFC destination'SAP_PROXY_ESR' in ECC System.

    Actually we thought that the connection test were working, but due to some other requirement the target system of the destination SAP_PROXY_ESR was changed to other server, the connection was not pointing to SAP PI thus no connectivity between SAP PI and SAP ECC.

    Once the parameters of the destination SAP_PROXY_ESR were changed, the newly created objects were available in ECC for proxy generation 😊

    Cheers!!!

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 08, 2016 at 04:13 PM

    Hi Ankit,

    AFIR in PI 7.0 i didn't use SAP_PROXY_ESR connection, there are another: How do you activate ABAP Proxies? | SCN

    Regards.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 08, 2016 at 02:38 PM

    Hi Ankit,

    Have you defined you SWC like local one?

    Have you set your namespace like http://sap.com/xi/...(Interface Object not showing in SPROXY. | SCN)?

    Regards.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 08, 2016 at 03:56 PM

    When I do a refresh on SPROXY of SAP PI where the issue is for no connection.

    It prompts for a user name and password for R3/ECC system.

    Any comments on it?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.