avatar image
Former Member

PI connectivity error

Hi,

While connecting my system with a .NET system and vice-versa, getting the following error --

<?xml version="1.0" ?>

- <!--

see the documentation

-->

- <SOAP:Envelope xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/">

- <SOAP:Body>

- <SOAP:Fault>

<faultcode>SOAP:Server</faultcode>

<faultstring>Server Error</faultstring>

- <detail>

- <s:SystemError xmlns:s="http://sap.com/xi/WebService/xi2.0">

<context>XIAdapter</context>

<code>ADAPTER.JAVA_EXCEPTION</code>

- <text>

- <![CDATA[

  1. com.sap.aii.af.mp.module.ModuleException: either no channelID specified or no channel found for the specified party, service, and channel name, MessageServlet(Version $Id: //tc/xi/NW04S_20_REL/src/_adapters/_soap/java/com/sap/aii/af/mp/soap/web/MessageServlet.java#1 $)

  at com.sap.aii.af.mp.soap.web.MessageServlet.doPost(MessageServlet.java:427)

  at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)

  at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

  at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.runServlet(HttpHandlerImpl.java:401)

  at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.handleRequest(HttpHandlerImpl.java:266)

  at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:386)

  at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:364)

  at com.sap.engine.services.httpserver.server.RequestAnalizer.invokeWebContainer(RequestAnalizer.java:1039)

  at com.sap.engine.services.httpserver.server.RequestAnalizer.handle(RequestAnalizer.java:265)

  at com.sap.engine.services.httpserver.server.Client.handle(Client.java:95)

  at com.sap.engine.services.httpserver.server.Processor.request(Processor.java:175)

  at com.sap.engine.core.service630.context.cluster.session.ApplicationSessionMessageListener.process(ApplicationSessionMessageListener.java:33)

  at com.sap.engine.core.cluster.impl6.session.MessageRunner.run(MessageRunner.java:41)

  at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)

  at java.security.AccessController.doPrivileged(Native Method)

  at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:104)

  at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:176)

]]>

</text>

</s:SystemError>

</detail>

</SOAP:Fault>

</SOAP:Body>

</SOAP:Envelope>



Can anyone have the clue how to resolve this out?


Thanks,


Suman.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Aug 08, 2016 at 09:22 AM

    Hello Suman,

    I think you have an problem whith your sender / receiver agreement.

    Suman Kundu wrote:


    either no channelID specified or no channel found for the specified party, service, and channel name, MessageServlet(Version $Id:

    When it´s the sender channel, please open the sender agreement and remove the assigned channel. Then save and activate the change. Then open the agreement again and assign (use F4 Value List) the channel, save and activate the change again.

    When the problem is with the receiver channel, do the same with the receiver Agreement.

    I think, your PI Team know how to do this.

    regards,

    Benedikt

    Add comment
    10|10000 characters needed characters exceeded

Skip to Content