Skip to Content
author's profile photo Former Member
Former Member

FPM/Webdynpro Apps Issues

Hi Experts,

I am using a central hub System which consists of Gateway System and Back-End S/4 HANA 1511 with highest support package level of each .

But when I am going to execute any of the FPM/Webdynpro apps, It throws the below error...

But I have checked with the System, In Gateway server the above application is not present but in Backend System the application is present.

As per the document which I am following, we supposed to create a RFC connection of type H.

Also I have created the RFC connection to Back-end System and tested that is OK with status code 200.

When I am going to Manage the System alias in SPRO I could not find the RFC connection of type H there..

And in LPD_CUST when I am going to change the System Alias It shows only the Locale system alias name..

Query : Is it related to any BI server and BW server. Because we are not using the BI server in Backend.

Please Suggest me what can I do to run these apps.

Regards,

Parthasarathi

co1.PNG (415.5 kB)
co2.PNG (24.5 kB)
co3.PNG (87.5 kB)
co5.PNG (56.5 kB)
co6.PNG (13.4 kB)
co8.PNG (146.0 kB)
co9.PNG (144.3 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Aug 03, 2016 at 07:17 AM

    Hi Parthasarathi,

    For RFC S4H_FINANCE, please also input the Service No of backend HTTP/HTTPS port.

    You can directly input the created RFC S4H_FINANCE into System Alias field of Cost Center in LPD_CUST.

    Then retry the APP.

    Regards,

    Ning

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Ning Tong

      Hi Ning,

      We have not configured the web Dispatcher yet. For FPM/Webdynpro Apps Should we configure the Web Dispstcher ?

      As of my knowledge We are using the S4 HANA as Back-End Server.

      We are using the Remote desktop to use the Gateway server and S4 HANA server.

      Please let me know elaborately about the back-end server.

      Regards,

      Parthasarathi

  • Posted on Aug 04, 2016 at 08:39 AM

    Hi Parthasarathi

    Doing the same at a customer myself... and getting further.

    You might want to map the system aliases centrally via transaction SM30 view /UI2/V_ALIASMAP

    Your HTTP or HTTPS destination should point to your S/4HANA 1511 backend system.

    Remember also that your users need to have S_RFC and S_RFCACL authorisations in the backend system.

    Have you checked your S/4HANA HTTP Connection itself is working correctly?

    It may be that you are missing some foundational ICF services.. A quick way is to go into your S/4HANA backend system, navigate to transaction SICF and test the webgui service. That will at least confirm host, port and other settings are ok.

    Rgds,

    Jocelyn

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Parthasarathi

      Ok well that's an improvement! At least it is heading to the correct system.

      1511 uses the NWBC framework to launch backend apps.

      You need to activate NWBC in the S/4HANA backend.

      Especially activate the SICF services in path /sap/bc/ui2/nwbc

      You might also want to check the rest of the instructions in the UI Technology Guide for S/4HANA via help.sap.com

      Good luck!

      Rgds,

      Jocelyn

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.