Skip to Content

Text Editor Error 'CSapEditorCtrl::GetObject: Object 15 does not exist'

After upgrading to GUI 740 I ran into this error when editing text in SO10. Numerous web and SAP notes suggest the re-installing the SAP legacy editor that is no longer part of the SAP GUI but Note 1907484 suggests using report RSCPSETEDITOR to force the setting of MS Word as the default editor. This which solved the issue for me. Also see Note 742662 which mentions using report RSCPINST to do the same thing.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jul 27, 2016 at 03:02 PM

    Hi Niall,

    This can be solved with this note 2221815 - SAPscript Legacy Text Editor controls are not packed in SAP Windows GUI Installation.

    In resume you need to download 'SAPSCRIPT LEGACY TEXT EDITOR' from SAP Software Download Center and install it.

    Best Regards,

    RNatu

    Add a comment
    10|10000 characters needed characters exceeded

    • Thanks Raul,

      I have seen the legacy editor solution but I want to move forward with what the SAP GUI is proposing by omitting it in the original package. The error is caused because the legacy sapedit editor is being referenced. Setting the default editor to MS Word negates the reference and hence the error.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.