Skip to Content

Webi Ignore Report Filter by "Export to CSV" SAP BI 4.1 Sp05 Pl 6

Hi together,

I have a webi report which will be exported to csv "Export to csv" for further usage in another system.. There is a program to read the csv file from BO..

The problem here is, that Webi ignores the Report filter by extraction "Export to csv" Therefore there are more than data records as expected.. Here not the Webi Report but rather the query result extracted..

Is there a solution in the next Patch Levels... ?? Any other proposal??

Export as Excel or Text or csv from Excel can not be loaded in this specific program.. The Program is created to read the Format from the file "Export as csv".

thanks

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Jul 27, 2016 at 09:17 AM

    If you are on BI 4.1 then you can use CSV Archive option to export the report data in the CSV.

    Add a comment
    10|10000 characters needed characters exceeded

    • Export to CSV will ignore the report level filters.either include your filters at webi query level.

      other option you can do to create one variable at report level and define the format.

      Schedule the report and select format "Text" and in destination put the custom report name ABC.csv

      uncheck the add file extension checkbox.

      You will get the data in CSV format.

      sample like

      Created Var Output=Char(34)+[State]+Char(34)+[Lines]+Char(34)+[Sales revenue]+Char(34)

      Untitled.png (44.8 kB)
  • author's profile photo Former Member
    Former Member
    Posted on Jul 29, 2016 at 09:26 AM

    Hello Team,

    This is expected behavior of Web Intelligence.

    When you export the report to CSV, it will export the data which is present in micro-cube (not report level data). And hence will ignore everything on report level.

    You can do export report to CSV Archive to achieve the requirement.

    Note: This functionality is not available in schedule.

    Regards,

    Mithilesh

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.