Skip to Content
author's profile photo Former Member
Former Member

Dropdown is not coming in Crystal Report

Dear All,

I have created Crystal Report using dynamic Parameter.

In development server I am getting drop down in input parameter (ref. ProperParaValue.png).


But now when I published it into Production server then in input parameter instead of getting drop down i am only getting blank textbox (ref DropdownMissing.png).

Kindly help me to solve this issue as early as possible.

Thanks,

ARPITA

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Jul 26, 2016 at 12:41 PM

    Hi Arpita,

    It is because, you / the user don't have privileges on Business View Manager on Production Server.

    Check with your BO admin, he need to provide sufficient rights for you on BVM.

    Thanks,

    Sastry

    Add a comment
    10|10000 characters needed characters exceeded

    • - Log in to the BVM with an Administrator account.

      - Cancel out of the default landing screen if it appears.

      - If the Repository Explorer is not visible, go to the View menu and turn it on.

      - Right-click on the "Dynamic Cascading Prompts" folder and select "Edit Rights". Make sure that the Everyone group has View access.

      The other thing you need to do verify the Data Connection for the prompt for this report.

      - If the prompt was originally created in the report and not in the BVM, get the name of the Prompt Group from the parameter definition in the report.

      - In the BVM, find the Data Foundation that has the same name as the Prompt Group. This should have a "_DF" suffix on the name.

      - Open the Data Foundation to determine which connection it's using. Right-click on "Tables" on the left and select "Set Table Location". A screen will appear that shows you the name of the Data Connection , which should have a suffix of "_DC".

      - Open the Data Connection by double-clicking on it. In the column on the left, there will be a bunch of information about the connection, including the credentials for the database. Do the following:

      1. Make sure that it's connecting to the correct database for the environment. If it's not, you may have to create a new one that does. When you do, the steps below also apply.

      2. Make sure that the User Name and Password information are correct for the connection,

      3. Set the "Runtime Prompt Mode" to "Never Prompt".

      - Save the connection.

      - If you had to create a new connection, edit the Data Foundation and use "Set Table Location" to change it to use the new connection. Then save the Data Foundation.

      -Dell

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.