Skip to Content

Help needed - SAP Hana installation is failing

Dear Experts,

this is my first post on Hana, hence please apologize, if I am posting in the wrong topic.

I'm trying to install a Hana test system in VMware. The installation somehow goes through,

but Hana isn't starting. I'm getting this:

Starting 7 processes on host 'han':

Starting on 'han': hdbcompileserver, hdbdaemon, hdbindexserver, hdbnameserver, hdbpreprocessor, hdbwebdispatcher, hdbxsengine

Starting on 'han': hdbcompileserver, hdbdaemon, hdbindexserver, hdbpreprocessor, hdbwebdispatcher, hdbxsengine

Starting on 'han': hdbcompileserver, hdbdaemon, hdbindexserver, hdbwebdispatcher, hdbxsengine

Starting on 'han': hdbdaemon, hdbindexserver, hdbwebdispatcher, hdbxsengine

Starting on 'han': hdbdaemon, hdbwebdispatcher, hdbxsengine

Starting on 'han': hdbdaemon, hdbwebdispatcher

Installation failed

error installing

Cannot create Instance

Cannot start system

Start instance 00 on local host failed.

FAIL: process hdbwebdispatcher HDB Web Dispatcher not running

Check the log file for SAP HANA Database error messages

Log file written to '/var/tmp/hdb_H00_install_

2016-07-22_18.56.37/hdbinst.log' on host 'han'.

And in this file, there is following:

18:57:52.544 - INFO: Starting 1 process on host 'han':

18:57:52.544 - INFO: Starting on 'han': hdbdaemon

18:57:56.550 - INFO: Starting 7 processes on host 'han':

18:57:56.550 - INFO: Starting on 'han': hdbcompileserver, hdbdaemon, hdbindexserver, hdbnameserver, hdbpreprocessor, hdbwebdispatcher, hdbxsengine

18:58:20.590 - INFO: Starting on 'han': hdbcompileserver, hdbdaemon, hdbindexserver, hdbpreprocessor, hdbwebdispatcher, hdbxsengine

18:58:26.603 - INFO: Starting on 'han': hdbcompileserver, hdbdaemon, hdbindexserver, hdbwebdispatcher, hdbxsengine

18:58:30.609 - INFO: Starting on 'han': hdbdaemon, hdbindexserver, hdbwebdispatcher, hdbxsengine

18:59:06.662 - INFO: Starting on 'han': hdbdaemon, hdbwebdispatcher, hdbxsengine

18:59:20.705 - INFO: Starting on 'han': hdbdaemon, hdbwebdispatcher

19:00:17.060 - ERR : FAIL: process hdbwebdispatcher HDB Web Dispatcher not running

19:00:17.061 - ERR : Start instance 00 on local host failed.

19:00:18.300 - INFO: Messages from trace files

19:00:17.093 - INFO: webdispatcher_han.30006_dev_

webdisp.old: [Thr 140262213940992] *** ERROR => Malloc(180711520) failed! Storing MPIs in heap memory failed! [mpixx.c 1092]
19:00:17.093 - INFO: webdispatcher_han.30006_dev_webdisp.old: [Thr 140262213940992] *** ERROR => IcmBufInit: MpiInit failed (rc=1) [icxxbuf.c 195]
19:00:17.093 - INFO: webdispatcher_han.30006_dev_webdisp.old: [Thr 140262213940992] *** ERROR => IcmInit: IcmBufInit failed (rc=1) [icxxman.c 2314]
19:00:17.095 - INFO: xsengine_alert_han.trc: More than 50 relevant messages found, check file.
19:00:17.145 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] *** ERROR => secussl_Create_SSL_CTX(): PSE "/usr/sap/H00/HDB00/han/sec/SAPSSLS.pse": File not found!
[ssslsecu.c 2395]
19:00:17.145 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] secussl_Create_SSL_CTX: SSL_CTX_set_default_pse_by_name() failed (4129/0x00001021)
19:00:17.145 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] >> ---------- Begin of Secu-SSL Errorstack ---------- >>
19:00:17.145 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] SAPCRYPTO API error
19:00:17.145 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] << ---------- End of Secu-SSL Errorstack ----------
19:00:17.145 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] *** ERROR => SapISSLAddCredential(): Error SSSLERR_PSE_ERROR trying to create SERVER Credential
19:00:17.145 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] *** ERROR => Initialization of SSL library failed -- NO SSL available!
19:00:17.145 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] <<- ERROR: SapSSLInit(read_profile=1)==SSSLERR_PSE_ERROR
19:00:17.145 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] *** WARNING => IcmServInitSSL: Creation of default PSE files failed: (rc=-40) [icxxserv.c 378]
19:00:17.145 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] *** ERROR => secussl_Create_SSL_CTX(): PSE "/usr/sap/H00/HDB00/han/sec/SAPSSLS.pse": unable to use!
[ssslsecu.c 2395]
19:00:17.145 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] secussl_Create_SSL_CTX: SSL_CTX_set_default_pse_by_name() failed (536872208/0x20000510)
19:00:17.145 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] >> ---------- Begin of Secu-SSL Errorstack ---------- >>
19:00:17.145 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] SSL API error
19:00:17.146 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] << ---------- End of Secu-SSL Errorstack ----------
19:00:17.146 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] *** ERROR => SapISSLAddCredential(): Error SSSLERR_PSE_ERROR trying to create SERVER Credential
19:00:17.146 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] *** ERROR => Initialization of SSL library failed -- NO SSL available!
19:00:17.146 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] <<- ERROR: SapSSLInit(read_profile=1)==SSSLERR_PSE_ERROR
19:00:17.146 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] *** ERROR => IcmServInitSSL: SapSSLInit (rc=-40): SSSLERR_PSE_ERROR [icxxserv.c 390]
19:00:17.146 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140281148167936] *** ERROR => IcmBufAllocHeap: malloc 65536 failed [icxxbuf.c 336]
19:00:17.146 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140281148167936] *** ERROR => IcmAdmMessageCreate: IcmBufAllocHeap failed (rc=-3) [icxxmsg.c 5411]
19:00:17.146 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140281148167936] *** ERROR => IcmCreateSubhdlInitMsg: IcmAdmMessageCreate failed (rc=-1) [icxxmsg.c 5132]
19:00:17.146 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140279564142336] *** ERROR => IcmCreateWorkerThreads: ThrCreate failed: Operation failed due to lack of resources. (rc=14) [icxxthr.c 908]
19:00:17.146 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140281148167936] *** ERROR => IcmConnPoolCreate: malloc failed [icxxpool.c 306]
19:00:17.146 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140281148167936] *** ERROR => IcmConnPoolCreate(2000) failed: -3 [ictxxroute.c 1046]
19:00:17.146 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140281148167936] *** ERROR => IcrIAddServerConnPools() failed 1 [ictxxroute.c 1466]
19:00:17.146 - INFO: webdispatcher_han.30006_dev_webdisp: [Thr 140281148167936] SEGV_MAPERR: Address not mapped to object
19:00:17.193 - INFO: webdispatcher_alert_han.trc: More than 50 relevant messages found, check file.
...

This line has caught my attention:

webdispatcher_han.30006_dev_webdisp: [Thr 140279344301824] *** ERROR => secussl_Create_SSL_CTX(): PSE "/usr/sap/H00/HDB00/han/sec/SAPSSLS.pse": File not found!

[ssslsecu.c 2395]

But I've checked and the file IS there:

ls -la "/usr/sap/H00/HDB00/han/sec/SAPSSLS.pse"

-rw-------. 1 h00adm sapsys 115 Jul 22 18:59 /usr/sap/H00/HDB00/han/sec/SAPSSLS.pse

Also, from HA200, I don't remember that webdispatcher is a mandatory process, so I have tried to remove it by editing daemon.ini, but now I see, that it was disabled again. I know that it says to modify it from the Management Studio, but I didn't install that yet...

Do you have any idea on how to fix this ? Many thanks for helping me out!

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Jul 26, 2016 at 12:20 PM

    Hi Symon,

    What is the size of memory in this host? Maybe it is not enough.

    Regards,

    Ning

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello Ning,

      sure that it's exactly as you are saying, but there is a switch to ignore that :-)

      For whatever reason it has been implemented...

      And as I said - I would totally agree, if I would see a single mention of an "out of memory"

      situation in the logs !! But as you can see in my initial post - nothing like that...

      Thank you!

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.