Skip to Content

Net Price shows zero in service PO line item

Hi Experts,

I have gone through lot many discussions on the same issue but I couldn't find the solution for my issue.

Actually we have created service po with two line items, service entry sheet and invoice for both line items but when I am going to check my PO system will show me net price zero for one line item.

System can not show P001 value in condition tab.

I have checked below given points in the system

1. P001 condition type in pricing procedure- statistical or not.

2. Routine 6 is assigned to P001.

3. System not allow to change net price manually in condition tab.

Please refer below given screen shot for your reference.

Thanks in advance.

1.png (61.8 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • Posted on Jul 26, 2016 at 07:54 AM

    Dear gurus,

    Please help me I am waiting for your replies.

    Add a comment
    10|10000 characters needed characters exceeded

    • Analyze your PO creation with transaction ANST, this can show you if you have any custom routines in the program that might cause this effect. If that is the case you may want to contact your ABAPer to check his coding, if this is not the case then I'd recommend to open a call at SAP Support.

  • Posted on Jul 26, 2016 at 07:15 AM

    And you did not come across a hint to click the analysis button below the conditions ?

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 26, 2016 at 07:22 AM

    Have you maintain the Qty and Gross price in Services tab of PO line item?

    -Joshua.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 27, 2016 at 07:16 AM

    Hi Sanjay

    There are 3 possible ways to make the line item price as zero.

    1. Free Goods indicator is checked for the item

    2. Invoice indication is not set

    3. Free goods are taken from Purchase Info Record

    Please check if any of the above settings are done for the item. Otherwise check with your abaper as suggested by Jurgen.

    Regards

    Raja

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 27, 2016 at 10:41 AM

    Hi Sanjay,

    It wouldn't the effect of vendor change until you change the schema group. If you change the vendor schema group also it won't effect on existing PO's. Can you share conditions of line 1 screenshot in item level.

    Regards,

    Raghu Raj

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 29, 2016 at 04:45 AM

    Hi all,

    Please help me to resolve this issue.

    Add a comment
    10|10000 characters needed characters exceeded

    • this cannot be an intentional behavior, this is a bug. You need to find out if there was some programming done inhouse (user exits, badis...) which could have caused this. It could also be a bug in a standard program, either never discovered before or the bug came new into the system with some updates or OSS notes.

      As you can replicated the case it should be relatively easy for an ABAPer to find the root cause

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.