Skip to Content
author's profile photo Former Member
Former Member

Input Parameter not Rrestricting values in the data preview

Hi,

I just cam across a strange issues I am trying to limit my data based on quarter and currency code.

Just for testing purpose I assigned quarter as input variables which is working perfectly fine.

But when I created input parameter and using it under calculated column I am getting all the data for all the currency codes so in short is not limiting to the input made by user.

Calculated columns: "CURRCODE"='$$Input_CURR_paramenter$$'

Attaching three screen shot as well.

Not sure why it is not capturing the input of currency.

I think I am missing some flow or some check ??????

Cheers,

SM

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Jul 24, 2016 at 05:56 AM

    Hi,

    did you define a calculated column or a filter expression on a column? A calculated column does not restrict the result set.

    Regards,

    Florian

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 25, 2016 at 02:17 PM

    Hi SM,

    Input parameter is to have list of values to be popped up at run time but just by creating data won't be filtered at data preview.

    And to do that, you have to apply filter on the column you want to filter, so context click on column CURRENCYCODE at data foundation node of analytic view and choose Apply Filter option where you can choose the created input parameter as shown by Krishna.

    This input parameter will be popped up at data preview where you can pass the value to filter accordingly.

    And Yes input parameter will be popped up only when it is being used somewhere in view either in calculated column or as filter, etc

    Regards,

    Shireesha

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.