Skip to Content

Syscopy based expo/imp from 10.2.0.2 to 12.1

Hi,

I've got a ECC system 6.00 BASIS 7.00 SP 18 on Windows 2003 SP2 X64 with Oracle 10.2.0.2. I would like a technology upgrade for this system... so next year it will be upgrade to the last ECC release (6.08 at last).

I would like to create new VMs (one for dev, one for tst and one for prd) with Windows 2012R2 and Oracle 12.1 with last available patches.

I will do it with a system copy based on export/import. Is it possible? I read several notes and documentations but I haven't find any problem. Is it enough BASIS 7.00 SP18 to run Oracle 12.1? I've find only an issue with statistics update solved by a note with code correction. Last SWMP, can it export the db from a 10.2.0.2 Oracle release?

Thank you so much.

Regards.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Jul 23, 2016 at 09:15 PM

    Hello,

    I believe using R3load base export/import method you can perform system copy from Oracle 10 to 12. There are no available notes in support of this method but considering that R3load export/import method is database independent it should work.

    Please refer below for all requisite steps related to Oracle 12 (Installation, SAP SP Version etc.)

    1914631 - Central Technical Note for Oracle Database 12c Release 1 (12.1)




    Thanks,

    Manish

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 09, 2016 at 09:14 PM

    R3load based system copy should let you move the system from 10g to 12c in one step. As long as you have supporting OS, kernel and BR*Tools for Oracle 12c, it should be alright. You do not need to patch the system to the required SP level, just apply the corrections delivered in the note 2157904 and transport it across other systems.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 10, 2016 at 07:23 AM

    Hello,

    Note 2133079, which you may have read, unambiguously states that NetWeaver 7.0 is supported with Oracle 12.1. There is no restriction as to the minimum SP level. The PAM confirms that the combination is supported (with Windows 2008, 2008R2, 2012 and 2012R2). Kernel on the target platform must be 721_EXT or 722_EXT.

    The only exception is for dual-stack ABAP/Java systems but your system being an ECC 6.0 that is unlikely to apply.

    R3load is not concerned with the Oracle catalog, only with the objects in the SAP schema. It will be able to handle Oracle 10 as the source database.

    Regards,

    Mark

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.