Skip to Content
author's profile photo Former Member
Former Member

AO - Issue with large workbook - Workbook redisplay taking a long time

Hi,

I have a workbook with one analysis connection (RFC) inserted into a tab of the report. The query / connection runs fine outside of the workbook - it returns in a number of seconds. However when embedded into an excel sheet with various formulas in excel the performance is very poor. The workbook is 9gb so it is very large - but there are no performance issues until i try to refresh the connection. I have done some analysis using the profiling statistics and the issue seems to be with the workbook redisplay - it is taking almost 15 mins to format the display in Excel. Has anyone else had this issue previously - i have searched and haven't found a solution.

I'm on analysis version 2.2 SP02 32 bit - with Office 2010 14.0

I have attached the statistics

Any ideas?

Thanks

Brian

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Jul 25, 2016 at 10:31 AM

    Hi Brian,

    are you sure, that your workbook is 9GB large? Maybe one of these notes help you:

    • 2039134
    • 2076788
    • 1899658

    BR,

    Tobias

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 26, 2016 at 08:18 AM

    Hi Brian,

    Which client do you use when running it 'outside' of Analysis? If using BEx Web then that would make sense as the BEx Web need to render only enough information for the current page. 9MB is fairly large - as far as I know there is a 10MB limit on workbooks so beware of this.

    Have you perhaps set the workbook to discard data before saving? That increases the file size as well - for some obscure reason.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Cobus,

      When I say outside of the workbook I just mean in another analysis workbook - with only the connection in the workbook and none of the excel functionality.

      I don't have the report set to discard the data before saving so this isn't an issue for me.

      Thanks for the suggestions

      Brian

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.