Skip to Content
author's profile photo Former Member
Former Member

OData call never returns the data

Experts,

Any thoughts on this one would be much appreciated.

  • I have an OData service that works perfectly fine in the source system. I can test it successfully through the gateway client without issue.
  • I've imported the service into my VERY basic list app in WebIDE. This is the code with the binding ...



  • All configuration is as another app that works as expected except, of course, for the OData service that is specific to this app.
  • I run the app, it thinks for a few seconds and returns no data. It's at this point that I figure it's not finding its way through to SAP.
  • However, I can execute the OData service successfully from my HCP app instance with no issues ...



  • I can see logs in my cloud connector showing that the service is being accessed and that the call to my on premise SAP system is working.
  • I set a remote break-point in SAP and when I run the app, it fires the break-point and the method executes successfully with data but no data is returned to the app.



Does anyone know what I should be looking for?

Any help would be much appreciated as this is very frustrating.

RSA1 List.jpg (566.3 kB)
RSA1 Code.jpg (73.8 kB)
RSA1 No Data.jpg (62.1 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jul 22, 2016 at 01:02 AM

    Hi Brad,

    What does it say in the console log in Chrome developer tools (or the browser's console)?

    -Aabhas

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Glad this resolved the issue, however, I hope some experts to explain why disabling $batch works and not when $batch mode is enabled. It could be to do with the way OData service is modelled in the back-end.

      If anyone can explain this, that will be great. Ideally, we should be using $batch to improve network performance.

      cheers,

      Aabhas

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.