Skip to Content

System disappeared in /TMWFLOW/CMSCONF

Hi

We have experienced a very strange issue that has me scratching my head.

In our SolMan system (we are on 7.1 SP12), I activated CSOL by going into /TMWFLOW/CMSCONF transaction. I activated this for a Development system called "DAC".

We have been making changes in this system for a few weeks now and CSOL has been working perfectly. However, users are now getting a RFC NONE error in DAC when trying to make changes (which is preventing them from saving the change).

I had a look and all my CSOL config in DAC (SM30 > BCOS_CUST) is gone! I am not sure how this happened. And I can't add it back because I get the RFC NONE error. No problem I thought, I will just temporarily turn off CSOL for DAC.

So I went into SolMan but now the DAC system (and UAC and PAC) are no longer showing in /TMWFLOW/CMSCONF (they are showing in Critical Objects tab but not System Change Options tab). So I can't turn off CSOL for DAC!!

I have tried everything to get these systems back. I have checked and all RFC's are working perfectly. All users (SMB_DAC and SM_PSM etc. have the correct authorizations) so it's definitely not that. I have tried creating a new project with DAC > UAC > PAC in ChaRM and creating a new Task List....this still didn't fix it.

I even tried refreshing RFC's in SMSY and then running /TMWFLOW/CONFIG_BATCH_GET program...this still did nothing.


I'm not sure what else to check. And we can't make any changes in DAC until this is resolved.

Any ideas?

Thanks!
Shaun

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Jul 21, 2016 at 05:49 AM
    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 21, 2016 at 07:40 AM

    Hi Shaun,

    as a last resort you could open the system in SCC4 and allow changes without recording, add the RFC back to the table BCOS_CUST , save and set the system back to what it was.

    CSOL should only jump in when you add objects to a transport.

    Hope your system isn't too busy 😊

    Strange and scary behavior though, if you get an answer or find a solution, please don't forget to share it here, others might experience the same.

    Cheers

    Markus

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 22, 2016 at 12:42 AM

    Thanks Vignesh and Markus.

    Vignesh - I had already checked that note. It is not applicable for our version of SolMan (we are on 7.1 SP12). I also already have a user in 000 of DAC with appropriate authorizations. I have checked the 000 RFC's in SolMan SMSY and these test fine (even though these shouldn't be needed for CSOL).

    Markus - yes, this is exactly what we did. Now CSOL is working again which is great.

    Yet, the DAC (and UAC and PAC) systems are still not showing in /TMWFLOW/CMSCONF and I have no idea why. I have literally tried everything.

    It's not a big issue because CSOL is now working again. But these systems used to appear in CMSCONF (this is where I originally activated CSOL) but now they are gone. Which means I cannot turn off CSOL for only DAC system if need be...

    Any other thoughts on why it's missing from CMSCONF?

    Thanks!

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.