Skip to Content
author's profile photo Former Member
Former Member

Incorrect log on parameters

We just installed Crystal Server 2016 ( on Windows Server 2012 R2). I installed the SQL Native Client 11 driver and created an ODBC connection to our database I have a Crystal Report that connects to a SQL Server db via the same 32-bit native client ODBC connection. The report runs fine in Crystal Reports locally on my PC. However, when deployed to Crystal Server, the report fails with the error "Error in File ~tmp2e3c8fa52a64a60.rpt: Unable to connect: incorrect log on parameters."

The database is SQL Server 2014. I remember struggling with this during initial set up at another job and thought the Native Client driver was the key. What am I missing? Should there be a connection in the Crystal Server UI? According to the PAM, SQL Server 2014 data access should use Microsoft SQL Server Native Client 11.0.

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Jul 20, 2016 at 03:33 PM

    Have you configured the database configuration for the report via CMC? You need to provide the ODBC connection name, Username and password in the required field. Along with the table prefix

    Just before saving the details make sure you select the option of "use the same database credential as and when report is run".

    Just make sure the same 32 bit ODBC connection is also there on the Business Objects Server

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 20, 2016 at 03:34 PM

    When you configured the ODBC connection, which version of the ODBC Manager did you use? Even though most of Crystal Reports Server is 64-bit, the part that actually runs Crystal reports is 32-bit. So, you MUST use the 32-bit ODBC manager to configure DSNs for reports. Use the 64-bit ODBC manager to configure DSNs for the CMS and Audit databases. Also, make sure that you created a System DSN on the server, NOT a User DSN.

    -Dell

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.