Skip to Content
0
Jul 19, 2016 at 01:30 PM

Weird issue - Unable to edit Edit Query Spec/Initial View in client

79 Views

Hi guys.

Recently I've started working on a new BO Server freshly deployed on a VM in the Cloud. The BOE version is 4.1 SP7.

Design Studio Server 1.6 SP1 is deployed on it.

I've created some Excel datasets and plugged some universes on it.

There, the weird behaviour starts :

  • Going through DS Client on my desktop, I'm able to see the Universe, but I'm unable to Edit the Query Specification (Failed to create CMS Session). When opening a document that already has defined datasources, I have this error : Cannot load InfoProvider "DSL/AZ2uU2q4oCxIoGJSdCEHY1c" (data provider "BCK_FILTER": No implementation service available)
  • Going through DS Client installed on the same VM than my BOE Server, I'm able to see the universes as well, but this time I'm able to Edit the Query Specification. But then when trying to edit the Initial View, I have this error : Cannot load InfoProvider "DSL/AZ2uU2q4oCxIoGJSdCEHY1c" (data provider "BCK_FILTER": Exception occurred during creation). Same error occurs when opening the document through the BI Platform.

THEN, if on the BOE Server I create a Webi document that uses the same datasources that in DS, everything is well initialized, and then if I go back to DS Client running on the VM and refresh the document, or refresh the document on the BI Platform, everything starts working fine.

Still, using my DS Client on my laptop won't work.

If I reboot the DS Service or the whole BOE, the errors start occurring again.

I've tried this : https://scn.sap.com/thread/3898878 but does not help.

I'm not an expert in CMC, do someone has some hints to resolve such issue?

Because it's painful to use remote DS Client on the VM and having to create a Webi document each time I want to work on the DS Dashboards.

Br,

Vincent