Skip to Content

Query in APD not giving results when divide data collection by packages is checked ?

Hi All,

I have a simple APD which is trying to read data from a Bex query and load it to Direct update DSO. I has been working fine for a long time in production but all of a sudden the DSO started picking up zero records. I have tried to calculate the intermediate results and it also gave no data. But if I execute the same query in outside APD, I am seeing values. I was wondering why ? Not sure what am I missing here.

I noticed that the "Divide data collection by packages" option in settings of the query in APD was checked for 0PLANT with package sizw = 5,000. If I un-check this option and calculate the intermediate results, I get my desired output. tried changing the package sizes but didnt work. Can anyone help me here ? I need a root cause as this is in a live system.

Thanks

Akhil

APD.PNG (19.8 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Jul 19, 2016 at 01:38 PM

    Hi Akhil,

    Please dont mention any Package size and try.

    Thanks,

    Anish Samuel


    APDD.JPG (26.8 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 19, 2016 at 11:53 AM

    Hi Akhil,

    Which is your BW version that you are having. Are you running the APD in background.How much data does the query hold.

    If you are running with packages sometimes there could be a memory issue in the app server leading to this issue. If you uncheck this option and if APD is running fine then you can continue as such

    Regards

    Gajesh

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.